aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/drm/libdrm_2.4.92.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-03 14:04:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-04 12:27:27 +0100
commit8dcebad54ded4fa9b3455b674be37ad0b10190d8 (patch)
treed3fa65b19371a4c6c1244d42d3c74ad5df90029b /meta/recipes-graphics/drm/libdrm_2.4.92.bb
parentbe194a459944dfcc41bae7315643a5d284683efc (diff)
downloadopenembedded-core-contrib-8dcebad54ded4fa9b3455b674be37ad0b10190d8.tar.gz
libdrm: port to Meson
Drop the patch to install tests as the Meson build allows this. Drop the patch to disable cunit as this predates recipe-specific-sysroots and isn't required anymore. As Meson always builds the test suite (instead of building before running it), add a patch to fix compilation with musl. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/drm/libdrm_2.4.92.bb')
-rw-r--r--meta/recipes-graphics/drm/libdrm_2.4.92.bb22
1 files changed, 9 insertions, 13 deletions
diff --git a/meta/recipes-graphics/drm/libdrm_2.4.92.bb b/meta/recipes-graphics/drm/libdrm_2.4.92.bb
index 2b3bf4f83d..347090cd5f 100644
--- a/meta/recipes-graphics/drm/libdrm_2.4.92.bb
+++ b/meta/recipes-graphics/drm/libdrm_2.4.92.bb
@@ -11,23 +11,19 @@ PROVIDES = "drm"
DEPENDS = "libpthread-stubs libpciaccess"
SRC_URI = "http://dri.freedesktop.org/libdrm/${BP}.tar.bz2 \
- file://installtests.patch \
- file://0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch \
- "
-
+ file://musl-ioctl.patch"
SRC_URI[md5sum] = "f9b00d985f82d0be6ecc20c799acc89e"
SRC_URI[sha256sum] = "e9e48fdb4de139dc4d9880aa1473158a16ff6aff63d14341367bd30a51ff39fa"
-inherit autotools pkgconfig manpages
+inherit meson pkgconfig manpages
+
+EXTRA_OEMESON = "-Dvalgrind=false \
+ -Dcairo-tests=false \
+ -Dinstall-test-programs=true \
+ -Domap=true \
+ -Detnaviv=true"
-EXTRA_OECONF += "--disable-cairo-tests \
- --without-cunit \
- --enable-omap-experimental-api \
- --enable-etnaviv-experimental-api \
- --enable-install-test-programs \
- --disable-valgrind \
- "
-PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"
+PACKAGECONFIG[manpages] = "-Dman-pages=true,-Dman-pages=false,libxslt-native xmlto-native"
ALLOW_EMPTY_${PN}-drivers = "1"
PACKAGES =+ "${PN}-tests ${PN}-drivers ${PN}-radeon ${PN}-nouveau ${PN}-omap \