aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/drm/libdrm_2.4.59.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-07-03 11:18:00 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-07 23:57:12 +0100
commitf71909f5eacc23d8533f1860ab890892d4f93f29 (patch)
tree3df60eb132634c5072ee8d68dfa1f4d7b845ea0e /meta/recipes-graphics/drm/libdrm_2.4.59.bb
parent080a7fbd876274410107732f175037fcea4d53ca (diff)
downloadopenembedded-core-contrib-f71909f5eacc23d8533f1860ab890892d4f93f29.tar.gz
libdrm: remove git recipe, merge inc
The git recipe hasn't been touched since 2012 and is out of date, so simplify the recipe by removing the git form and merging the remaining bb and inc file. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/drm/libdrm_2.4.59.bb')
-rw-r--r--meta/recipes-graphics/drm/libdrm_2.4.59.bb41
1 files changed, 38 insertions, 3 deletions
diff --git a/meta/recipes-graphics/drm/libdrm_2.4.59.bb b/meta/recipes-graphics/drm/libdrm_2.4.59.bb
index 14bf44affb..97f75ff029 100644
--- a/meta/recipes-graphics/drm/libdrm_2.4.59.bb
+++ b/meta/recipes-graphics/drm/libdrm_2.4.59.bb
@@ -1,6 +1,41 @@
-require libdrm.inc
-
-SRC_URI += "file://installtests.patch "
+SUMMARY = "Userspace interface to the kernel DRM services"
+DESCRIPTION = "The runtime library for accessing the kernel DRM services. DRM \
+stands for \"Direct Rendering Manager\", which is the kernel portion of the \
+\"Direct Rendering Infrastructure\" (DRI). DRI is required for many hardware \
+accelerated OpenGL drivers."
+HOMEPAGE = "http://dri.freedesktop.org"
+SECTION = "x11/base"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://xf86drm.c;beginline=9;endline=32;md5=c8a3b961af7667c530816761e949dc71"
+PROVIDES = "drm"
+DEPENDS = "libpthread-stubs udev libpciaccess"
+SRC_URI = "http://dri.freedesktop.org/libdrm/${BP}.tar.bz2 \
+ file://installtests.patch "
SRC_URI[md5sum] = "d32a1d37c2546ee11fc5924abeedb23e"
SRC_URI[sha256sum] = "68d26e1fd85582f4243d66864f9b43ca4ee93662825de32b5506fc8e181ea41b"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--disable-cairo-tests \
+ --enable-omap-experimental-api \
+ --enable-install-test-programs \
+ --disable-manpages \
+ "
+
+ALLOW_EMPTY_${PN}-drivers = "1"
+PACKAGES =+ "${PN}-tests ${PN}-drivers ${PN}-radeon ${PN}-nouveau ${PN}-omap \
+ ${PN}-intel ${PN}-exynos ${PN}-kms ${PN}-freedreno"
+
+RRECOMMENDS_${PN}-drivers = "${PN}-radeon ${PN}-nouveau ${PN}-omap ${PN}-intel \
+ ${PN}-exynos ${PN}-freedreno"
+
+FILES_${PN}-tests = "${bindir}/dr* ${bindir}/mode* ${bindir}/*test"
+FILES_${PN}-radeon = "${libdir}/libdrm_radeon.so.*"
+FILES_${PN}-nouveau = "${libdir}/libdrm_nouveau.so.*"
+FILES_${PN}-omap = "${libdir}/libdrm_omap.so.*"
+FILES_${PN}-intel = "${libdir}/libdrm_intel.so.*"
+FILES_${PN}-exynos = "${libdir}/libdrm_exynos.so.*"
+FILES_${PN}-kms = "${libdir}/libkms*.so.*"
+FILES_${PN}-freedreno = "${libdir}/libdrm_freedreno.so.*"
+