summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-11-06 08:36:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-07 10:56:24 +0000
commitd1635d80c2e0c8680c0af9966eb6007700601c39 (patch)
tree0eafada7a1a42a5ff76eef716e64902d5e899390 /meta/recipes-gnome
parent4643d1eb222151384f77d13a936537aae5ca3fe6 (diff)
downloadopenembedded-core-contrib-d1635d80c2e0c8680c0af9966eb6007700601c39.tar.gz
librsvg: Disable 64bit atomics on riscv32/mipsel in crossbeam
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/librsvg/librsvg_2.52.3.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-gnome/librsvg/librsvg_2.52.3.bb b/meta/recipes-gnome/librsvg/librsvg_2.52.3.bb
index 6c4850271d..f1d1a8f9f4 100644
--- a/meta/recipes-gnome/librsvg/librsvg_2.52.3.bb
+++ b/meta/recipes-gnome/librsvg/librsvg_2.52.3.bb
@@ -39,7 +39,9 @@ export RUST_TARGET_PATH
export RUST_TARGET = "${HOST_SYS}"
RUSTFLAGS:append:mips = " --cfg crossbeam_no_atomic_64"
+RUSTFLAGS:append:mipsel = " --cfg crossbeam_no_atomic_64"
RUSTFLAGS:append:powerpc = " --cfg crossbeam_no_atomic_64"
+RUSTFLAGS:append:riscv32 = " --cfg crossbeam_no_atomic_64"
# rust-cross writes the target linker binary into target json definition without any flags.
# This breaks here because the linker isn't going to work without at least knowing where