aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-27 21:00:58 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-27 22:42:49 +0100
commit6c12d0b8a44a91382d3aa064ebef43769d909e73 (patch)
treeda9b1cf8229063c0b3ae49a61137c9044eb47d88 /meta/recipes-gnome
parent65b7489f406e1d0a03a232f6e1ee3cf55a5f5bd2 (diff)
downloadopenembedded-core-contrib-6c12d0b8a44a91382d3aa064ebef43769d909e73.tar.gz
gtk-doc: Handle floating gtk-doc dependency
Allow the tests to be explicitly disabled to avoid floating dependnecy issues. This is not really an issue with RSS but is on previous releases. Currently the tests are enabled/disabled depending on the presence of glib-2.0. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gtk-doc/files/conditionaltests.patch34
-rw-r--r--meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb2
2 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gtk-doc/files/conditionaltests.patch b/meta/recipes-gnome/gtk-doc/files/conditionaltests.patch
new file mode 100644
index 0000000000..0c180f2605
--- /dev/null
+++ b/meta/recipes-gnome/gtk-doc/files/conditionaltests.patch
@@ -0,0 +1,34 @@
+Allow the tests to be explicitly disabled to avoid floating dependnecy
+issues. This is not really an issue with RSS but is on previous releases.
+
+RP 2017/6/27
+Upstream-Status: Pending
+
+Index: gtk-doc-1.25/configure.ac
+===================================================================
+--- gtk-doc-1.25.orig/configure.ac
++++ gtk-doc-1.25/configure.ac
+@@ -161,6 +161,11 @@ if test "x$GCC" = "xyes"; then
+ fi
+ fi
+
++AC_ARG_ENABLE([tests],
++ AS_HELP_STRING([--enable-tests],
++ [enable tests (default=yes)]),,
++ [enable_tests="yes"])
++
+ dnl if glib is available we can enable the tests
+ PKG_CHECK_MODULES(TEST_DEPS, [glib-2.0 >= 2.6.0 gobject-2.0 >= 2.6.0],
+ [ glib_prefix="`$PKG_CONFIG --variable=prefix glib-2.0`"
+@@ -171,6 +176,11 @@ PKG_CHECK_MODULES(TEST_DEPS, [glib-2.0 >
+ build_tests="no"
+ ]
+ )
++if test "x$enable_tests" != "xyes"; then
++ gtk_doc_use_libtool="no"
++ build_tests="no"
++fi
++
+ AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, test -n "$LIBTOOL" -a x$gtk_doc_use_libtool = xyes )
+ dnl this enable the rule in test/Makefile.am
+ AM_CONDITIONAL(BUILD_TESTS, test x$build_tests = xyes)
diff --git a/meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb b/meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb
index 7de36ae9e5..e0eb994e25 100644
--- a/meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb
+++ b/meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb
@@ -16,6 +16,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "api-documentation",
# hopefully no one minds because its scripts are not used for anything during build
# and shouldn't be used on targets.
PACKAGECONFIG[working-scripts] = "--with-highlight=source-highlight,--with-highlight=no,libxslt-native xmlto-native source-highlight-native perl-native"
+PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,glib-2.0"
# We cannot use host perl, because it may be too old for gtk-doc
EXTRANATIVEPATH += "perl-native"
@@ -23,6 +24,7 @@ EXTRANATIVEPATH += "perl-native"
SRC_URI += "file://0001-Do-not-hardocode-paths-to-perl-python-in-scripts.patch \
file://0001-Do-not-error-out-if-xsltproc-is-not-found.patch \
file://0001-Do-not-error-out-if-perl-is-not-found-or-its-version.patch \
+ file://conditionaltests.patch \
"
SRC_URI_append_class-native = " file://pkg-config-native.patch"