aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-09-05 22:25:44 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-09 12:12:17 +0100
commit755724d9d5f023450392ae8025a0cb6264283028 (patch)
tree3633d00df1a2f8bbdec72e124dd7d4a556615aae /meta/recipes-gnome
parent50768af29ce8524f7bae387996aaed657a1ff80f (diff)
downloadopenembedded-core-contrib-755724d9d5f023450392ae8025a0cb6264283028.tar.gz
gtk-doc: use pkg-config-native in native gtk-doc.m4
When building gtk-doc-native the m4 functions for autoconf should use pkg-config-native instead of pkg-config so that they can find the native tooling. This means that it is possible to generate gtk-doc without building the target packages. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gtk-doc/files/pkg-config-native.patch34
-rw-r--r--meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb2
2 files changed, 35 insertions, 1 deletions
diff --git a/meta/recipes-gnome/gtk-doc/files/pkg-config-native.patch b/meta/recipes-gnome/gtk-doc/files/pkg-config-native.patch
new file mode 100644
index 0000000000..c7688704eb
--- /dev/null
+++ b/meta/recipes-gnome/gtk-doc/files/pkg-config-native.patch
@@ -0,0 +1,34 @@
+Use native pkg-config when looking for gtk-doc.
+
+Upstream-Status: Inappropriate
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/gtk-doc.m4 b/gtk-doc.m4
+index 3675543..94881ae 100644
+--- a/gtk-doc.m4
++++ b/gtk-doc.m4
+@@ -1,6 +1,6 @@
+ dnl -*- mode: autoconf -*-
+
+-# serial 2
++# serial 2.1
+
+ dnl Usage:
+ dnl GTK_DOC_CHECK([minimum-gtk-doc-version])
+@@ -10,11 +10,16 @@ AC_DEFUN([GTK_DOC_CHECK],
+ AC_BEFORE([AC_PROG_LIBTOOL],[$0])dnl setup libtool first
+ AC_BEFORE([AM_PROG_LIBTOOL],[$0])dnl setup libtool first
+
++ gtkdoc_pkgconfig_save=$PKG_CONFIG
++ PKG_CONFIG=pkg-config-native
++
+ ifelse([$1],[],[gtk_doc_requires="gtk-doc"],[gtk_doc_requires="gtk-doc >= $1"])
+ AC_MSG_CHECKING([for gtk-doc])
+ PKG_CHECK_EXISTS([$gtk_doc_requires],[have_gtk_doc=yes],[have_gtk_doc=no])
+ AC_MSG_RESULT($have_gtk_doc)
+
++ PKG_CONFIG=$gtkdoc_pkgconfig_save
++
+ if test "$have_gtk_doc" = "no"; then
+ AC_MSG_WARN([
+ You will not be able to create source packages with 'make dist'
diff --git a/meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb b/meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb
index 9b9f191e0c..3d1cdae385 100644
--- a/meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb
+++ b/meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb
@@ -20,6 +20,7 @@ PACKAGECONFIG[working-scripts] = "--with-highlight=source-highlight,--with-highl
SRC_URI += "file://0001-Do-not-hardocode-paths-to-perl-python-in-scripts.patch \
file://0001-Do-not-error-out-if-xsltproc-is-not-found.patch \
"
+SRC_URI_append_class-native = " file://pkg-config-native.patch"
SRC_URI[archive.md5sum] = "0dc6570953112a464a409fb99258ccbc"
SRC_URI[archive.sha256sum] = "1ea46ed400e6501f975acaafea31479cea8f32f911dca4dff036f59e6464fd42"
@@ -45,4 +46,3 @@ gtkdoc_makefiles_sysroot_preprocess() {
-e "s|GTKDOC_RUN =.*|GTKDOC_RUN = \$(top_builddir)/gtkdoc-qemuwrapper|" \
${SYSROOT_DESTDIR}${datadir}/gtk-doc/data/gtk-doc*make
}
-