aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-21 14:47:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-25 09:33:36 +0100
commit9ea9d61f26a942dbbc90070b40ba0209021a4b46 (patch)
tree8827550ffe6fa977b3150231a98d47fa05163492 /meta/recipes-gnome
parentcde1b85d402f5999814de4022e3b6ddc90b4604a (diff)
downloadopenembedded-core-contrib-9ea9d61f26a942dbbc90070b40ba0209021a4b46.tar.gz
gtk-doc: don't regenerate gtk-doc in do_install
In out-of-tree builds gtk-doc's setup-build target copies all the content from $srcdir to $builddir. However, if some of this content is regenerated at configure time this can happen: 1) configure writes new build/version.xml 2) make compile copies content, including the tarball's src/version.xml to build/version.xml, and generates gtk-doc. 3) make install notices build/version.xml is older than configure.status, so regenerates gtk-doc. gtk-doc generation is a slow process at the best of times, so doing it twice isn't good. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gtk-doc/files/no-clobber.patch27
-rw-r--r--meta/recipes-gnome/gtk-doc/gtk-doc_1.27.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gtk-doc/files/no-clobber.patch b/meta/recipes-gnome/gtk-doc/files/no-clobber.patch
new file mode 100644
index 0000000000..0fa22b2097
--- /dev/null
+++ b/meta/recipes-gnome/gtk-doc/files/no-clobber.patch
@@ -0,0 +1,27 @@
+In out-of-tree builds gtk-doc's setup-build target copies all the content from $srcdir to $builddir.
+
+However, if some of this content is regenerated at configure time this can happen:
+
+1) configure writes new build/version.xml
+2) make compile copies content, including the tarball's src/version.xml
+ to build/version.xml, and generates gtk-doc.
+3) make install notices build/version.xml is older than configure.status,
+ so regenerates gtk-doc.
+
+gtk-doc generation is a slow process at the best of times, so doing it twice isn't good.
+
+Solve this by changing cp --force to cp --no-clobber, so setup-build only copies
+files which don't already exist.
+
+Upstream-Status: Submitted [https://bugzilla.gnome.org/show_bug.cgi?id=794571]
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/gtk-doc.make b/gtk-doc.make
+index f87eaab..246f3c0 100644
+--- a/gtk-doc.make
++++ b/gtk-doc.make
+@@ -113,3 +113,3 @@ setup-build.stamp:
+ test -f $(abs_srcdir)/$$file && \
+- cp -pf $(abs_srcdir)/$$file $(abs_builddir)/$$file || true; \
++ cp -pn $(abs_srcdir)/$$file $(abs_builddir)/$$file || true; \
+ done; \
diff --git a/meta/recipes-gnome/gtk-doc/gtk-doc_1.27.bb b/meta/recipes-gnome/gtk-doc/gtk-doc_1.27.bb
index b907bae147..45528111c1 100644
--- a/meta/recipes-gnome/gtk-doc/gtk-doc_1.27.bb
+++ b/meta/recipes-gnome/gtk-doc/gtk-doc_1.27.bb
@@ -23,6 +23,7 @@ SRC_URI[archive.sha256sum] = "e26bd3f7080c749b1cb66c46c6bf8239e2f320a949964fb9c6
SRC_URI += "file://0001-Do-not-hardocode-paths-to-perl-python-in-scripts.patch \
file://0001-Do-not-error-out-if-xsltproc-is-not-found.patch \
file://conditionaltests.patch \
+ file://no-clobber.patch \
"
SRC_URI_append_class-native = " file://pkg-config-native.patch"