aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-17 12:53:16 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-18 09:27:13 +0100
commit10e0c1a3a452baa05d160a92a54b2e33cf0fd061 (patch)
tree0879ca25bb0793b1e8b4bc0194cbb87ed2af6483 /meta/recipes-gnome
parent2b44e468d20a0256fba896562e2e7d1ae593a4c8 (diff)
downloadopenembedded-core-contrib-10e0c1a3a452baa05d160a92a54b2e33cf0fd061.tar.gz
gobject-introspection: Ensure prelink config file exists to avoid build failures
gobject-introspection relies upon prelink-rtld. In order to function correctly, we generate an ld.so.conf file which is generated before users of prelink-rtld are called. There is currently a race in gobject-introspection since the configuration file may not have been created. This adds in code to ensure that regardless of codepath (new build, existing build, from sstate), we trigger the creation of the configuration file and avoid build failures. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb
index 6948aff2fa..eca6ce00a0 100644
--- a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb
+++ b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb
@@ -158,3 +158,16 @@ gi_binaries_sysroot_preprocess() {
-e "s|g_ir_compiler=.*|g_ir_compiler=${bindir}/g-ir-compiler-wrapper|" \
${SYSROOT_DESTDIR}${libdir}/pkgconfig/gobject-introspection-1.0.pc
}
+
+# Need to ensure ld.so.conf exists so prelink-native works
+# both before we build and if we install from sstate
+do_configure[prefuncs] += "gobject_introspection_preconfigure"
+python gobject_introspection_preconfigure () {
+ oe.utils.write_ld_so_conf(d)
+}
+
+SSTATEPOSTINSTFUNCS += "gobject_introspection_postinst"
+python gobject_introspection_postinst () {
+ if d.getVar("BB_CURRENTTASK", True).startswith("populate_sysroot"):
+ oe.utils.write_ld_so_conf(d)
+}