summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/librsvg/librsvg_2.52.3.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-11-05 09:48:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-07 08:44:58 +0000
commit97562668e1a76710acd2be7c8cdbcc1deb80bd9f (patch)
tree5495feb0390e9fbac935a3f090d460516d422e93 /meta/recipes-gnome/librsvg/librsvg_2.52.3.bb
parentabb4f439cdb364f7b04da8bd452fc18dbe44e67e (diff)
downloadopenembedded-core-contrib-97562668e1a76710acd2be7c8cdbcc1deb80bd9f.tar.gz
librsvg: set the needed atomic configuration flags directly per-target
Do not try to mangle the upstream list of targets; after discussion with upstream it turns out it's neither necessary nor upstreamable: https://github.com/crossbeam-rs/crossbeam/pull/751 Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/librsvg/librsvg_2.52.3.bb')
-rw-r--r--meta/recipes-gnome/librsvg/librsvg_2.52.3.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-gnome/librsvg/librsvg_2.52.3.bb b/meta/recipes-gnome/librsvg/librsvg_2.52.3.bb
index 335d891f05..6c4850271d 100644
--- a/meta/recipes-gnome/librsvg/librsvg_2.52.3.bb
+++ b/meta/recipes-gnome/librsvg/librsvg_2.52.3.bb
@@ -18,7 +18,6 @@ inherit gnomebase gtk-doc pixbufcache upstream-version-is-even gobject-introspec
SRC_URI += "file://0001-Makefile.am-pass-rust-target-to-cargo-also-when-not-.patch \
file://0001-system-deps-src-lib.rs-do-not-probe-into-harcoded-li.patch \
- file://0001-crossbeam-utils-check-only-the-architecture-not-the-.patch \
file://0001-vendor-system-deps-sort-dependencies-before-using-th.patch \
file://0005-Add-base-definitions-for-riscv64-musl-libc-0.2.93.patch \
file://0006-FIXUP-linux-musl-mod.rs-add-riscv64-to-b64-set-libc-.patch \
@@ -39,6 +38,9 @@ export RUST_TARGET_PATH
export RUST_TARGET = "${HOST_SYS}"
+RUSTFLAGS:append:mips = " --cfg crossbeam_no_atomic_64"
+RUSTFLAGS:append:powerpc = " --cfg crossbeam_no_atomic_64"
+
# rust-cross writes the target linker binary into target json definition without any flags.
# This breaks here because the linker isn't going to work without at least knowing where
# the sysroot is. So copy the json to workdir, and patch in the path to wrapper from rust class