aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gtk+
diff options
context:
space:
mode:
authorValentin Popa <valentin.popa@intel.com>2014-02-20 12:09:36 +0200
committerSaul Wold <sgw@linux.intel.com>2014-02-20 20:06:23 -0800
commitc885365107cc31ba2eff94cfae4f09813ac53a97 (patch)
tree6c44d529ec3e973222490f817d2e656fc4e90fcf /meta/recipes-gnome/gtk+
parent2d51215dbfcde7a9ead430ca8c127944c77ceb40 (diff)
downloadopenembedded-core-contrib-c885365107cc31ba2eff94cfae4f09813ac53a97.tar.gz
gtk+3: upgrade to 3.10.7
(*) removed patches that were already commited upstream (*) added new patch to solve the build issue (*) changed the package URL because the old one is unreliable. Signed-off-by: Valentin Popa <valentin.popa@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-gnome/gtk+')
-rw-r--r--meta/recipes-gnome/gtk+/gtk+3/fix-build-when-wayland-backend-enabled.patch43
-rw-r--r--meta/recipes-gnome/gtk+/gtk+3/no-x11-in-wayland.patch32
-rw-r--r--meta/recipes-gnome/gtk+/gtk+3/wayland-attach.patch42
-rw-r--r--meta/recipes-gnome/gtk+/gtk+3_3.10.7.bb (renamed from meta/recipes-gnome/gtk+/gtk+3_3.8.2.bb)9
4 files changed, 47 insertions, 79 deletions
diff --git a/meta/recipes-gnome/gtk+/gtk+3/fix-build-when-wayland-backend-enabled.patch b/meta/recipes-gnome/gtk+/gtk+3/fix-build-when-wayland-backend-enabled.patch
new file mode 100644
index 0000000000..b4b1a09455
--- /dev/null
+++ b/meta/recipes-gnome/gtk+/gtk+3/fix-build-when-wayland-backend-enabled.patch
@@ -0,0 +1,43 @@
+Fix build when wayland backend enabled
+
+Upstream-Status: Submitted
+https://bugzilla.gnome.org/show_bug.cgi?id=710584
+
+Author: Emilio Pozuelo Monfort
+
+--- gtk+-3.10.7/gtk/gtkapplication.c
++++ gtk+-3.10.7/gtk/gtkapplication.c
+@@ -144,7 +144,6 @@
+
+ gboolean register_session;
+
+-#ifdef GDK_WINDOWING_X11
+ guint next_id;
+
+ GDBusConnection *session_bus;
+@@ -161,7 +160,6 @@
+ GDBusProxy *client_proxy;
+ gchar *app_id;
+ gchar *client_path;
+-#endif
+
+ #ifdef GDK_WINDOWING_QUARTZ
+ GMenu *combined;
+@@ -299,6 +297,8 @@
+ g_free (application->priv->client_path);
+ }
+
++#endif
++
+ const gchar *
+ gtk_application_get_app_menu_object_path (GtkApplication *application)
+ {
+@@ -311,8 +311,6 @@
+ return application->priv->menubar_path;
+ }
+
+-#endif
+-
+ #ifdef GDK_WINDOWING_QUARTZ
+
+ typedef struct {
diff --git a/meta/recipes-gnome/gtk+/gtk+3/no-x11-in-wayland.patch b/meta/recipes-gnome/gtk+/gtk+3/no-x11-in-wayland.patch
deleted file mode 100644
index df0921acbd..0000000000
--- a/meta/recipes-gnome/gtk+/gtk+3/no-x11-in-wayland.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-The Wayland backend was including X11 headers, which won't work in a no-X11
-distro.
-
-Upstream-Status: Backport
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-From 875b1d07ded377b20acbf1a10cae847f56de05b4 Mon Sep 17 00:00:00 2001
-From: Matthias Clasen <mclasen@redhat.com>
-Date: Thu, 23 May 2013 12:26:26 -0400
-Subject: [PATCH] Don't include X11 headers in wayland
-
-The include of X11/keysyms.h in gdkdevice-wayland.c was just
-a leftover.
----
- gdk/wayland/gdkdevice-wayland.c | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/gdk/wayland/gdkdevice-wayland.c b/gdk/wayland/gdkdevice-wayland.c
-index c258be3..cd4a695 100644
---- a/gdk/wayland/gdkdevice-wayland.c
-+++ b/gdk/wayland/gdkdevice-wayland.c
-@@ -32,7 +32,6 @@
- #include "gdkdevicemanagerprivate.h"
-
- #include <xkbcommon/xkbcommon.h>
--#include <X11/keysym.h>
-
- #include <sys/time.h>
- #include <sys/mman.h>
---
-1.7.10.4
-
diff --git a/meta/recipes-gnome/gtk+/gtk+3/wayland-attach.patch b/meta/recipes-gnome/gtk+/gtk+3/wayland-attach.patch
deleted file mode 100644
index fa0d0e6529..0000000000
--- a/meta/recipes-gnome/gtk+/gtk+3/wayland-attach.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Wayland 1.1 is enforcing the protocol whereas 1.0 was lenient. Backport a patch
-from git to fix repainting.
-
-Upstream-Status: Backport
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-
-From 0d2c4617203c8fe907c722c9cb53c0345e0405e7 Mon Sep 17 00:00:00 2001
-From: Scott Moreau <oreaus@gmail.com>
-Date: Sun, 10 Mar 2013 10:51:01 -0600
-Subject: [PATCH] wayland: Always attach buffer before committing
-
-With recent changes in attach semantics, we always need to attach before
-committing. Without this changes to the window contents to not get reflected
-in the content of the surface.
-
-Signed-off-by: Rob Bradford <rob@linux.intel.com>
----
- gdk/wayland/gdkwindow-wayland.c | 7 -------
- 1 file changed, 7 deletions(-)
-
-diff --git a/gdk/wayland/gdkwindow-wayland.c b/gdk/wayland/gdkwindow-wayland.c
-index 112a1f4..fa01e90 100644
---- a/gdk/wayland/gdkwindow-wayland.c
-+++ b/gdk/wayland/gdkwindow-wayland.c
-@@ -327,13 +327,6 @@ gdk_wayland_window_attach_image (GdkWindow *window)
- if (GDK_WINDOW_DESTROYED (window))
- return;
-
-- /* The "drawn to" Cairo surface is the same as the Cairo surface from which
-- * we are driving the buffer for the Wayland surface. Therefore we don't
-- * need to do anything here
-- */
-- if (impl->server_surface == impl->cairo_surface)
-- return;
--
- /* The wayland surface is attached to a buffer that is from the old "drawn
- * to" surface. Unref the surface and restore the state.
- */
---
-1.7.10.4
-
diff --git a/meta/recipes-gnome/gtk+/gtk+3_3.8.2.bb b/meta/recipes-gnome/gtk+/gtk+3_3.10.7.bb
index 5db3745dc4..9f8c6abebc 100644
--- a/meta/recipes-gnome/gtk+/gtk+3_3.8.2.bb
+++ b/meta/recipes-gnome/gtk+/gtk+3_3.10.7.bb
@@ -2,13 +2,12 @@ require gtk+3.inc
MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
-SRC_URI = "http://download.gnome.org/sources/gtk+/${MAJ_VER}/gtk+-${PV}.tar.xz \
+SRC_URI = "http://ftp.gnome.org/pub/gnome/sources/gtk+/${MAJ_VER}/gtk+-${PV}.tar.xz \
file://hardcoded_libtool.patch \
- file://no-x11-in-wayland.patch \
- file://wayland-attach.patch"
+ file://fix-build-when-wayland-backend-enabled.patch"
-SRC_URI[md5sum] = "8e878e18fc385f2b813419dc7b40a968"
-SRC_URI[sha256sum] = "1ca80c9c15a1df95d74cefb8c2afe4682ba272a4b489106f04877be2a7aff297"
+SRC_URI[md5sum] = "18a81944a8506231529a76bf2b68372b"
+SRC_URI[sha256sum] = "b7e9de15385031cff43897e7e59f6692eaabf500f36eef80e6b9d6486ad49427"
S = "${WORKDIR}/gtk+-${PV}"