aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gtk+
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-04-08 18:06:41 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-08 16:56:01 +0100
commitf2cb906bdce08441a20eab927ca9e2a2a9735ed0 (patch)
tree029d4473f6e972d1b349f9ce7e43e0122cacb9fc /meta/recipes-gnome/gtk+
parent0bdde53e885aae3506c7b070b6e21f64a7cd4115 (diff)
downloadopenembedded-core-contrib-f2cb906bdce08441a20eab927ca9e2a2a9735ed0.tar.gz
gtk-update-icon-cache-native: create wrapper script
When using the sstate from another build machine, the path to the pixbuf loader's cache points to a path on the remote machine. Hence, the update of the icon cache fails on host. Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/gtk+')
-rw-r--r--meta/recipes-gnome/gtk+/gtk-update-icon-cache-native_3.4.4.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gtk+/gtk-update-icon-cache-native_3.4.4.bb b/meta/recipes-gnome/gtk+/gtk-update-icon-cache-native_3.4.4.bb
index 93c30a75b1..73b7644845 100644
--- a/meta/recipes-gnome/gtk+/gtk-update-icon-cache-native_3.4.4.bb
+++ b/meta/recipes-gnome/gtk+/gtk-update-icon-cache-native_3.4.4.bb
@@ -40,4 +40,8 @@ do_compile() {
do_install() {
install -d ${D}${bindir}
install -m 0755 ${B}/gtk-update-icon-cache ${D}${bindir}
+
+ create_wrapper ${D}/${bindir}/gtk-update-icon-cache \
+ GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/2.10.0/loaders.cache
+
}