aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gtk+/gtk+_2.24.25.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-12-19 19:52:36 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-31 08:11:47 +0000
commit9299b5d2e5f82cf0e3f66ca49dedbe2c8b18bb44 (patch)
treef23bd3bb90e9950aa6c73de5850d0bf1be3077f6 /meta/recipes-gnome/gtk+/gtk+_2.24.25.bb
parentdbfe7d6eb2a292efe25f43ca2f5b3bb476a6210d (diff)
downloadopenembedded-core-contrib-9299b5d2e5f82cf0e3f66ca49dedbe2c8b18bb44.tar.gz
gtk+: upgrade to 2.24.25
Remove patches that are no longer needed: * GtkButton-do-no-prelight: merged upstream * Duplicate-the-exec-string: upstream decided this behaviour is incorrect * cellrenderer-cairo: Cairo isn't the performance bottleneck it once was, drop * configure-nm: resolved upstrea * configurefix.patch: not applied * run-iconcache: not needed when building tarballs, and if gtk-update-icon-cache is needed at build time (e.g. user is customising default icon theme) then they can add a dependency on gtk-update-icon-cache-native. Also remove mention of patches that have been commented out for a long time. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-gnome/gtk+/gtk+_2.24.25.bb')
-rw-r--r--meta/recipes-gnome/gtk+/gtk+_2.24.25.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gtk+/gtk+_2.24.25.bb b/meta/recipes-gnome/gtk+/gtk+_2.24.25.bb
new file mode 100644
index 0000000000..ada79567e7
--- /dev/null
+++ b/meta/recipes-gnome/gtk+/gtk+_2.24.25.bb
@@ -0,0 +1,33 @@
+require gtk+.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
+ file://gtk/gtk.h;endline=27;md5=c59e0b4490dd135a5726ebf851f9b17f \
+ file://gdk/gdk.h;endline=27;md5=07db285ec208fb3e0bf7d861b0614202 \
+ file://tests/testgtk.c;endline=27;md5=262db5db5f776f9863e56df31423e24c"
+SRC_URI = "http://ftp.gnome.org/pub/gnome/sources/gtk+/2.24/gtk+-${PV}.tar.xz \
+ file://xsettings.patch \
+ file://hardcoded_libtool.patch \
+ file://toggle-font.diff;striplevel=0 \
+ file://doc-fixes.patch \
+ "
+
+SRC_URI[md5sum] = "612350704dd3aacb95355a4981930c6f"
+SRC_URI[sha256sum] = "38af1020cb8ff3d10dda2c8807f11e92af9d2fa4045de61c62eedb7fbc7ea5b3"
+
+EXTRA_OECONF = "--enable-xkb --disable-glibtest --disable-cups --disable-xinerama"
+
+LIBV = "2.10.0"
+
+PACKAGES_DYNAMIC += "^gtk-immodule-.* ^gtk-printbackend-.*"
+
+python populate_packages_prepend () {
+ gtk_libdir = d.expand('${libdir}/gtk-2.0/${LIBV}')
+ immodules_root = os.path.join(gtk_libdir, 'immodules')
+ printmodules_root = os.path.join(gtk_libdir, 'printbackends');
+
+ d.setVar('GTKIMMODULES_PACKAGES', ' '.join(do_split_packages(d, immodules_root, '^im-(.*)\.so$', 'gtk-immodule-%s', 'GTK input module for %s')))
+ do_split_packages(d, printmodules_root, '^libprintbackend-(.*)\.so$', 'gtk-printbackend-%s', 'GTK printbackend module for %s')
+
+ if (d.getVar('DEBIAN_NAMES', True)):
+ d.setVar('PKG_${PN}', '${MLPREFIX}libgtk-2.0')
+}