summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gtk+/gtk+3
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2020-02-05 17:32:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-06 12:16:02 +0000
commitf3675be6be29426688187a135221431a0941d007 (patch)
treeba5990a20aa315f59c8e1426310580cfaebed7e1 /meta/recipes-gnome/gtk+/gtk+3
parent0392fcbdc85180581ce7392212808ebb822cc2e8 (diff)
downloadopenembedded-core-contrib-f3675be6be29426688187a135221431a0941d007.tar.gz
gtk+3: sort resources for reproducible binaries
The list of resources is gathered with $(wildcard) in Make, which isn't sorted. If this order changes then the generated libraries will differ. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/gtk+/gtk+3')
-rw-r--r--meta/recipes-gnome/gtk+/gtk+3/sort-resources.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gtk+/gtk+3/sort-resources.patch b/meta/recipes-gnome/gtk+/gtk+3/sort-resources.patch
new file mode 100644
index 0000000000..7f87372c52
--- /dev/null
+++ b/meta/recipes-gnome/gtk+/gtk+3/sort-resources.patch
@@ -0,0 +1,19 @@
+If the resources file isn't sorted in some way then libgdk.so will differ
+depending on the inode order of the resource files.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/gdk/Makefile.am b/gdk/Makefile.am
+index e25b57ba50..26f2d57c6e 100644
+--- a/gdk/Makefile.am
++++ b/gdk/Makefile.am
+@@ -465,7 +465,7 @@ stamp-gc-h: $(top_builddir)/config.status
+ # Resources
+ #
+
+-glsl_sources := $(wildcard $(srcdir)/resources/glsl/*.glsl)
++glsl_sources := $(sort $(wildcard $(srcdir)/resources/glsl/*.glsl))
+
+ gdk.gresource.xml: Makefile.am
+ $(AM_V_GEN) echo "<?xml version='1.0' encoding='UTF-8'?>" > $@; \