aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gtk+/gtk+3
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-03-28 10:03:59 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-04 11:53:15 +0100
commit3f3e249b98182fa50358ade9278e3e26454275b8 (patch)
treea74d92205071b6fbceb25ce824357694bcc66a27 /meta/recipes-gnome/gtk+/gtk+3
parenta0745234e78d9161d407f2157dc494fed4487d42 (diff)
downloadopenembedded-core-contrib-3f3e249b98182fa50358ade9278e3e26454275b8.tar.gz
gtk+3: set proper FLAGS for native
The target gtk+3 does a native build in its "native" directory, we need unset the target FLAGS for native build, otherwise, there might be build failures. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/gtk+/gtk+3')
-rw-r--r--meta/recipes-gnome/gtk+/gtk+3/fix-flags-for-native.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gtk+/gtk+3/fix-flags-for-native.patch b/meta/recipes-gnome/gtk+/gtk+3/fix-flags-for-native.patch
new file mode 100644
index 0000000000..9ae1088e01
--- /dev/null
+++ b/meta/recipes-gnome/gtk+/gtk+3/fix-flags-for-native.patch
@@ -0,0 +1,33 @@
+From 5e16904f94b5f5961f8f6e75716e6d7d228de119 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Fri, 28 Mar 2014 03:10:12 +0000
+Subject: [PATCH] gtk/native/Makefile.am: unset target FLAGS for native build
+
+The target gtk+3 does a native build in its "native" directory, we need
+unset the target FLAGS for native build, otherwise, there might be build
+failures.
+
+Upstream-Status: Pending
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ gtk/native/Makefile.am | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/gtk/native/Makefile.am b/gtk/native/Makefile.am
+index 64899e9..a1c814a 100644
+--- a/gtk/native/Makefile.am
++++ b/gtk/native/Makefile.am
+@@ -3,6 +3,9 @@ AM_CFLAGS = @CFLAGS_FOR_BUILD@
+ CPP = @CPP_FOR_BUILD@
+ AM_CPPFLAGS = @CPPFLAGS_FOR_BUILD@
+ AM_LDFLAGS = @LDFLAGS_FOR_BUILD@
++CFLAGS =
++CPPFLAGS =
++LDFLAGS =
+
+ if CROSS_COMPILING
+ if !USE_EXTERNAL_ICON_CACHE
+--
+1.8.3.4
+