aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-24 12:22:24 -0800
committerSaul Wold <Saul.Wold@intel.com>2010-11-24 13:25:20 -0800
commitb3934f3a5b590424867ae3352edee9f1d8d8ec5e (patch)
tree78693da7e23c1db4edd209a4240e54d00c928bb9 /meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb
parent4127ac1ba230699b2f4a6be45db87fb46cf9a2d9 (diff)
downloadopenembedded-core-contrib-b3934f3a5b590424867ae3352edee9f1d8d8ec5e.tar.gz
libart-lgpl: Update to version 2.3.21
Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb')
-rw-r--r--meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb b/meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb
new file mode 100644
index 0000000000..3bdd697145
--- /dev/null
+++ b/meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Library of functions for 2D graphics"
+SECTION = "x11/gnome"
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
+PR = "r1"
+
+ART_CONFIG = "${HOST_ARCH}/art_config.h"
+
+# can't use gnome.oeclass due to _ in filename
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libart_lgpl/2.3/libart_lgpl-${PV}.tar.bz2 \
+ file://${ART_CONFIG} \
+ file://Makefile.am.patch;patch=1"
+
+inherit autotools pkgconfig
+
+DEPENDS = ""
+
+FILES_${PN} = "${libdir}/*.so.*"
+FILES_${PN}-dev += "${bindir}/libart2-config"
+
+S = "${WORKDIR}/libart_lgpl-${PV}"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/${ART_CONFIG} ${S}/art_config.h
+}
+
+EXTRA_OECONF = "--disable-gtk-doc"
+