aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb
diff options
context:
space:
mode:
authorNathan Rossi <nathan.rossi@xilinx.com>2015-04-29 17:44:34 +1000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-03 11:39:48 +0100
commit91f3255ad700736bbf5d1b35b48db1708676a469 (patch)
tree9bf5d5a0191860c2c462c1a2c11ba16ce2d10a34 /meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb
parent1e2fd0a55a523d7e24275da23b801618dd9f82c5 (diff)
downloadopenembedded-core-contrib-91f3255ad700736bbf5d1b35b48db1708676a469.tar.gz
libart_lgpl: Allow art_config.h to be generated at compile time
* Remove patch that prevents the Makefile from generating the art_config.h file * Remove pre-generated art_config.h for various architecture * Add a do_compile prepend to remove the art_config.h that is provided in the source so that the compilation will regenerate the file Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb')
-rw-r--r--meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb12
1 files changed, 5 insertions, 7 deletions
diff --git a/meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb b/meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb
index 4966ea4c7a..138461684c 100644
--- a/meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb
+++ b/meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb
@@ -4,12 +4,8 @@ LICENSE = "LGPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
PR = "r2"
-ART_CONFIG = "${HOST_ARCH}/art_config.h"
-
# can't use gnome.oeclass due to _ in filename
-SRC_URI = "${GNOME_MIRROR}/libart_lgpl/2.3/libart_lgpl-${PV}.tar.bz2 \
- file://${ART_CONFIG} \
- file://Makefile.am.patch"
+SRC_URI = "${GNOME_MIRROR}/libart_lgpl/2.3/libart_lgpl-${PV}.tar.bz2"
SRC_URI[md5sum] = "08559ff3c67fd95d57b0c5e91a6b4302"
SRC_URI[sha256sum] = "fdc11e74c10fc9ffe4188537e2b370c0abacca7d89021d4d303afdf7fd7476fa"
@@ -23,6 +19,8 @@ FILES_${PN}-dev += "${bindir}/libart2-config"
S = "${WORKDIR}/libart_lgpl-${PV}"
-do_configure_prepend() {
- cp ${WORKDIR}/${ART_CONFIG} ${S}/art_config.h
+do_compile_prepend() {
+ # enforce regeneration of art_config.h
+ rm ${S}/art_config.h
}
+