summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gcr
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-03-09 17:02:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-12 22:11:18 +0000
commit1011ce60412b17e4a1d2293dabe76027547429f7 (patch)
tree3368d443f153ad2d6d6fce9bf0537c61b6ae0856 /meta/recipes-gnome/gcr
parent12d61ac95b6bfae60dd4a7c7239bc8b8b0bcafbb (diff)
downloadopenembedded-core-contrib-1011ce60412b17e4a1d2293dabe76027547429f7.tar.gz
recipes-gnome: fix introspection support
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/gcr')
-rw-r--r--meta/recipes-gnome/gcr/gcr_3.18.0.bb22
1 files changed, 20 insertions, 2 deletions
diff --git a/meta/recipes-gnome/gcr/gcr_3.18.0.bb b/meta/recipes-gnome/gcr/gcr_3.18.0.bb
index ed6e8c453f..32523a64aa 100644
--- a/meta/recipes-gnome/gcr/gcr_3.18.0.bb
+++ b/meta/recipes-gnome/gcr/gcr_3.18.0.bb
@@ -5,9 +5,9 @@ BUGTRACKER = "https://bugzilla.gnome.org/"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
-DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt vala"
+DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt"
-inherit autotools gnomebase gtk-icon-cache gtk-doc distro_features_check upstream-version-is-even
+inherit autotools gnomebase gtk-icon-cache gtk-doc distro_features_check upstream-version-is-even vala gobject-introspection
# depends on gtk+3, but also x11 through gtk+-x11
REQUIRED_DISTRO_FEATURES = "x11"
@@ -21,3 +21,21 @@ FILES_${PN} += " \
# http://errors.yoctoproject.org/Errors/Details/20229/
ARM_INSTRUCTION_SET = "arm"
+
+# on x86-64 the introspection binary goes into
+# an infinite loop under qemu during compilation,
+# printing the following:
+#
+# gcrypt-Message: select() error: Bad address
+#
+# gcrypt-Message: select() error: Bad address
+#
+# gcrypt-Message: select() error: Bad address
+#
+# This will be investigated later.
+EXTRA_OECONF_append_x86-64 = " --disable-introspection"
+
+# Gcr-3.broken: poky/build-mips64/tmp/work/mips64-poky-linux/libgpg-error/1.19-r0/libgpg-error-1.19/src/posix-lock.c:119: get_lock_object: Assertion `!"sizeof lock obj"' failed.
+# qemu: uncaught target signal 6 (Aborted) - core dumped
+EXTRA_OECONF_append_mips64 = " --disable-introspection"
+