aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-11-15 16:45:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-07 06:33:58 -0800
commite3e8c2ec038c95d8203c4886ef46aec6b0741837 (patch)
tree80fd4d5cf2cd41168fb0f2d97db9a3371c504edd /meta/recipes-extended
parentfc856d4539a13f1ea6bf7ce347e9ca85577ecfb8 (diff)
downloadopenembedded-core-contrib-e3e8c2ec038c95d8203c4886ef46aec6b0741837.tar.gz
libaio: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libaio/libaio/destdir.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-extended/libaio/libaio/destdir.patch b/meta/recipes-extended/libaio/libaio/destdir.patch
index dad9601c49..0f90406bee 100644
--- a/meta/recipes-extended/libaio/libaio/destdir.patch
+++ b/meta/recipes-extended/libaio/libaio/destdir.patch
@@ -2,16 +2,16 @@ Upstream-Status: Pending
from openembedded, added by Qing He <qing.he@intel.com>
-Index: libaio-0.3.106/Makefile
+Index: libaio-0.3.110/Makefile
===================================================================
---- libaio-0.3.106.orig/Makefile 2004-02-26 07:25:10.000000000 -0800
-+++ libaio-0.3.106/Makefile 2006-10-14 09:19:07.000000000 -0700
-@@ -15,7 +15,7 @@
+--- libaio-0.3.110.orig/Makefile
++++ libaio-0.3.110/Makefile
+@@ -15,7 +15,7 @@ all:
@$(MAKE) -C src
install:
- @$(MAKE) -C src install prefix=$(prefix) includedir=$(includedir) libdir=$(libdir)
+ @$(MAKE) -C src install prefix=$(DESTDIR)$(prefix) includedir=$(DESTDIR)$(includedir) libdir=$(DESTDIR)$(libdir)
-
- clean:
+ check:
+ @$(MAKE) -C harness check