aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-04 19:25:17 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-06 06:13:59 -0800
commit79e1d94e6c08610971c66637a59149b8b9c0ab72 (patch)
treef3661661800bc9e8d40bb040fe70e70b222acd5d /meta/recipes-extended
parentf593f9eedcb3e96b1904bc8250ce9353130de62b (diff)
downloadopenembedded-core-contrib-79e1d94e6c08610971c66637a59149b8b9c0ab72.tar.gz
libxml-sax-perl: inherit ptest-perl
* Enable ptest by inheriting new ptest-perl.bbclass * Install testfiles/ into PTEST_PATH Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/perl/libxml-sax-perl_0.99.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb b/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
index ad31b9c9d2..cdcbebffce 100644
--- a/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
+++ b/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
@@ -23,6 +23,11 @@ SRC_URI[sha256sum] = "32b04b8e36b6cc4cfc486de2d859d87af5386dd930f2383c49347050d6
S = "${WORKDIR}/XML-SAX-${PV}"
-inherit cpan
+inherit cpan ptest-perl
+
+do_install_ptest() {
+ cp -r ${B}/testfiles ${D}${PTEST_PATH}
+ chown -R root:root ${D}${PTEST_PATH}/testfiles
+}
BBCLASSEXTEND = "native"