aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorZhang Xiao <xiao.zhang@windriver.com>2017-08-25 08:42:38 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-27 22:29:44 +0100
commita2b278a6eaa9e9b48d858e3be6712267c0122598 (patch)
tree8aae146994ea4cb6dcac67461a1714530be25ecc /meta/recipes-extended
parenta615b0825927a09a0aa8312d131c9acbaef8956d (diff)
downloadopenembedded-core-contrib-a2b278a6eaa9e9b48d858e3be6712267c0122598.tar.gz
bash: memleak bug fix for builtin command read
Built in command "read" with "-e" use Readline to obtain the line in an interactive shell. In this process, a string "rlbuf" is just allocated without free operation thus cause memory leak. This patch had been submitted to upstream: http://lists.gnu.org/archive/html/bug-bash/2017-02/msg00061.html Signed-off-by: Zhang Xiao <xiao.zhang@windriver.com> Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/bash/bash/bash-memleak-bug-fix-for-builtin-command-read.patch35
-rw-r--r--meta/recipes-extended/bash/bash_4.4.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/bash/bash/bash-memleak-bug-fix-for-builtin-command-read.patch b/meta/recipes-extended/bash/bash/bash-memleak-bug-fix-for-builtin-command-read.patch
new file mode 100644
index 0000000000..9fb6ba972b
--- /dev/null
+++ b/meta/recipes-extended/bash/bash/bash-memleak-bug-fix-for-builtin-command-read.patch
@@ -0,0 +1,35 @@
+From d3b6303a6853f612a56848ee4e59eaa0b0ab9489 Mon Sep 17 00:00:00 2001
+From: Zhang Xiao <xiao.zhang@windriver.com>
+Date: Tue, 21 Feb 2017 11:30:14 +0800
+Subject: [PATCH] bash: memleak bug fix for builtin command read
+
+Built in command "read" with "-e" use Readline to obtain the line
+in an interactive shell. In this process, a string "rlbuf" is
+just allocated without free operation thus cause memory leak. Fix it.
+
+Upstream-Status: Submitted [http://lists.gnu.org/archive/html/bug-bash/2017-02/msg00061.html]
+
+Signed-off-by: Zhang Xiao <xiao.zhang@windriver.com>
+---
+ builtins/read.def | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/builtins/read.def b/builtins/read.def
+index 4397154..ee0c5a6 100644
+--- a/builtins/read.def
++++ b/builtins/read.def
+@@ -674,6 +674,11 @@ add_char:
+ input_string[i] = '\0';
+ CHECK_ALRM;
+
++#if defined (READLINE)
++ if (edit)
++ xfree (rlbuf);
++#endif
++
+ if (retval < 0)
+ {
+ t_errno = errno;
+--
+1.9.1
+
diff --git a/meta/recipes-extended/bash/bash_4.4.bb b/meta/recipes-extended/bash/bash_4.4.bb
index b602afe8ac..e544d07c10 100644
--- a/meta/recipes-extended/bash/bash_4.4.bb
+++ b/meta/recipes-extended/bash/bash_4.4.bb
@@ -25,6 +25,7 @@ SRC_URI = "${GNU_MIRROR}/bash/${BP}.tar.gz;name=tarball \
file://run-ptest \
file://fix-run-builtins.patch \
file://0001-help-fix-printf-format-security-warning.patch \
+ file://bash-memleak-bug-fix-for-builtin-command-read.patch \
"
SRC_URI[tarball.md5sum] = "148888a7c95ac23705559b6f477dfe25"