aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-03-15 22:01:50 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-16 16:41:20 +0000
commita1bb79372e75269b8d135c0018955c533ba06027 (patch)
tree13376c0810211d3a969922340caf555e5d5cce3b /meta/recipes-extended
parenta0682191e0743ed8ec1d30567eb26d4cde864ee8 (diff)
downloadopenembedded-core-contrib-a1bb79372e75269b8d135c0018955c533ba06027.tar.gz
libzypp: Fix release query
Libzypp is looking for the "redhat-release" file and using that version number to help adjust the system version. This ensures that there is something on the system that returns a correct value. This patch is likely not necessary. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libzypp/libzypp/config-release.patch21
-rw-r--r--meta/recipes-extended/libzypp/libzypp_git.bb3
2 files changed, 23 insertions, 1 deletions
diff --git a/meta/recipes-extended/libzypp/libzypp/config-release.patch b/meta/recipes-extended/libzypp/libzypp/config-release.patch
new file mode 100644
index 0000000000..9128237755
--- /dev/null
+++ b/meta/recipes-extended/libzypp/libzypp/config-release.patch
@@ -0,0 +1,21 @@
+Configure distro version package
+
+We need to configure a package that the system can use to determine the
+system distribution version.
+
+Hack: for now set to task-poky-rpm.
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff -ur git.orig/zypp/ZConfig.cc git/zypp/ZConfig.cc
+--- git.orig/zypp/ZConfig.cc 2011-03-14 16:30:07.492786134 -0500
++++ git/zypp/ZConfig.cc 2011-03-15 11:39:15.396801927 -0500
+@@ -821,7 +821,7 @@
+ ///////////////////////////////////////////////////////////////////
+
+ std::string ZConfig::distroverpkg() const
+- { return "redhat-release"; }
++ { return "task-poky-rpm"; }
+
+ ///////////////////////////////////////////////////////////////////
+
diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb
index 825339d126..621ce45da4 100644
--- a/meta/recipes-extended/libzypp/libzypp_git.bb
+++ b/meta/recipes-extended/libzypp/libzypp_git.bb
@@ -13,7 +13,7 @@ RDEPENDS_${PN} = "sat-solver"
S = "${WORKDIR}/git"
PV = "0.0-git${SRCPV}"
-PR = "r7"
+PR = "r8"
SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
file://no-doc.patch \
@@ -22,6 +22,7 @@ SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
file://builtin-arch.patch;apply=no \
file://no-builtin-arch.patch;apply=no \
file://archconf.patch;apply=no \
+ file://config-release.patch \
"
SRC_URI_append_mips = " file://mips-workaround-gcc-tribool-error.patch"