summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2021-03-22 11:23:30 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-23 22:51:20 +0000
commita0dc36d60809a0a937bbb02ec27ba768ef177063 (patch)
treefc888ca04418b23b5254f9b0f6c9637049aa06fa /meta/recipes-extended
parentb6c2df341d7e6da5defca9a5567fdb7212489efa (diff)
downloadopenembedded-core-contrib-a0dc36d60809a0a937bbb02ec27ba768ef177063.tar.gz
go-helloworld: disable module-aware mode
>From go 1.16, module-aware mode is enabled by default, regardless of whether a go.mod file is present in the current working directory or a parent directory. Above change makes go-helloworld build fail when doing offline build or proxy.golang.org is not accessible. This fix is kind of workaround, as from go1.17, GOPATH mode will be dropped, and GO111MODULE is ignored. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/go-examples/go-helloworld_0.1.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
index d3f7525dc9..c51f163e9b 100644
--- a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
+++ b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
@@ -6,14 +6,15 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
SRC_URI = "git://${GO_IMPORT}"
-SRCREV = "bcf50bfd7dcd8020c90965747d857ae42802e0c5"
+SRCREV = "46695d81d1fae905a270fb7db8a4d11a334562fe"
UPSTREAM_CHECK_COMMITS = "1"
GO_IMPORT = "github.com/golang/example"
GO_INSTALL = "${GO_IMPORT}/hello"
GO_WORKDIR = "${GO_INSTALL}"
+export GO111MODULE="off"
-inherit go-mod
+inherit go
# This is just to make clear where this example is
do_install_append() {