aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorYu Ke <ke.yu@intel.com>2011-07-13 16:58:27 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-13 12:14:12 +0100
commitd415c10f8488e0cc4b175ad3d985748d07bbedaa (patch)
treeb518967231c5717a4e6384eb088ae855c72f1941 /meta/recipes-extended
parentf4de87ce30a37bb2f09855d442b34d153ada8c0e (diff)
downloadopenembedded-core-contrib-d415c10f8488e0cc4b175ad3d985748d07bbedaa.tar.gz
libzypp: fix for non /usr/lib libdir case
this patch has two fixes: 1. the src tool/CMakeLists.txt has hardcode "lib", so add a patch to fix it 2. the recipe has hardcode "-DLIB=lib", so replace it with libdir Signed-off-by: Yu Ke <ke.yu@intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libzypp/libzypp/hardcode-lib-fix.patch22
-rw-r--r--meta/recipes-extended/libzypp/libzypp_git.bb5
2 files changed, 25 insertions, 2 deletions
diff --git a/meta/recipes-extended/libzypp/libzypp/hardcode-lib-fix.patch b/meta/recipes-extended/libzypp/libzypp/hardcode-lib-fix.patch
new file mode 100644
index 0000000000..c11f5c53c9
--- /dev/null
+++ b/meta/recipes-extended/libzypp/libzypp/hardcode-lib-fix.patch
@@ -0,0 +1,22 @@
+tools/CMakeLists.txt: replace the hardcode "lib"
+
+replace the hardcode "lib" with LIB_INSTALL_DIR
+this will work with non /usr/lib libdir case
+
+Upstream-Status: Pending
+
+Signed-off-by: Yu Ke <ke.yu@intel.com>
+
+Index: libzypp/tools/CMakeLists.txt
+===================================================================
+--- libzypp.orig/tools/CMakeLists.txt
++++ libzypp/tools/CMakeLists.txt
+@@ -1,7 +1,7 @@
+
+ ADD_SUBDIRECTORY( package-manager )
+
+-INSTALL( FILES notify-message DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/zypp" )
++INSTALL( FILES notify-message DESTINATION "${LIB_INSTALL_DIR}/zypp" )
+
+ ## ############################################################
+
diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb
index 824f7a1339..6555bd4044 100644
--- a/meta/recipes-extended/libzypp/libzypp_git.bb
+++ b/meta/recipes-extended/libzypp/libzypp_git.bb
@@ -14,7 +14,7 @@ RDEPENDS_${PN} = "sat-solver"
S = "${WORKDIR}/git"
SRCREV = "15b6c52260bbc52b3d8e585e271b67e10cc7c433"
PV = "0.0-git${SRCPV}"
-PR = "r10"
+PR = "r11"
SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
file://no-doc.patch \
@@ -23,6 +23,7 @@ SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
file://config-release.patch \
file://libzypp-pokyarch.patch \
file://fix_for_compile_wth_gcc-4.6.0.patch \
+ file://hardcode-lib-fix.patch \
"
SRC_URI_append_mips = " file://mips-workaround-gcc-tribool-error.patch"
@@ -33,7 +34,7 @@ SRC_URI_append_arm = " file://arm-workaround-global-constructor.patch"
FILES_${PN} += "${libdir}/zypp ${datadir}/zypp ${datadir}/icons"
FILES_${PN}-dev += "${datadir}/cmake"
-EXTRA_OECMAKE += "-DLIB=lib"
+EXTRA_OECMAKE += " -DLIB=${@os.path.basename('${libdir}')}"
PACKAGE_ARCH = "${MACHINE_ARCH}"