summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-20 09:23:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-20 18:57:29 +0100
commita2c85d3cac2a6c4cd8e961e915e9567ef2fc2c0b (patch)
treec55aa497bacc56ee04b3407d0eb4aa2d744f9bf8 /meta/recipes-extended
parentcbd17e7a9641d628f4222b3af320d808d7037eea (diff)
downloadopenembedded-core-contrib-a2c85d3cac2a6c4cd8e961e915e9567ef2fc2c0b.tar.gz
zstd: Include pzstd in the build
We don't currently build the parallel version of zstd but we should. Add this to the build. It will then be used in buildtools-tarball. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/zstd/zstd_1.5.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-extended/zstd/zstd_1.5.0.bb b/meta/recipes-extended/zstd/zstd_1.5.0.bb
index 806edb63c3..3786058731 100644
--- a/meta/recipes-extended/zstd/zstd_1.5.0.bb
+++ b/meta/recipes-extended/zstd/zstd_1.5.0.bb
@@ -29,10 +29,12 @@ ZSTD_LEGACY_SUPPORT ??= "4"
do_compile () {
oe_runmake ${PACKAGECONFIG_CONFARGS} ZSTD_LEGACY_SUPPORT=${ZSTD_LEGACY_SUPPORT}
+ oe_runmake ${PACKAGECONFIG_CONFARGS} ZSTD_LEGACY_SUPPORT=${ZSTD_LEGACY_SUPPORT} -C contrib/pzstd
}
do_install () {
oe_runmake install 'DESTDIR=${D}'
+ oe_runmake install 'DESTDIR=${D}' PREFIX=${prefix} -C contrib/pzstd
}
BBCLASSEXTEND = "native nativesdk"