summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@gmail.com>2021-05-25 15:40:47 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-27 13:20:44 +0100
commit6090bec1261726e5290f50e9cd22e42952253ed5 (patch)
tree9883e4f770e095fe619cde2a62568d77997f153a /meta/recipes-extended
parentb9c983eb22a9b0771a0454216d1d7cbb5f3f8a16 (diff)
downloadopenembedded-core-contrib-6090bec1261726e5290f50e9cd22e42952253ed5.tar.gz
libarchive: enable zstd support
Now that zstd is in oe-core, add PACKAGECONFIG for it and enabled it by default in libarchive. zstd support is expected by CMake, which in nativesdk depends on libarchive. CMake depends on having all formats supported and build issues can arise when zstd is not available: https://gitlab.kitware.com/cmake/cmake/-/issues/21552 Quote from a CMake dev: "As far as CMake's design is concerned, we have no optional formats. All should be supported. That's why we bundle sufficiently new versions of libarchive and libzstd. If a distro builds with an older libarchive that doesn't have zstd support, then that is not a proper packaging of CMake." Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libarchive/libarchive_3.5.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_3.5.1.bb b/meta/recipes-extended/libarchive/libarchive_3.5.1.bb
index c9e30f468f..ebecee1f3e 100644
--- a/meta/recipes-extended/libarchive/libarchive_3.5.1.bb
+++ b/meta/recipes-extended/libarchive/libarchive_3.5.1.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d499814247adaee08d88080841cb5665"
DEPENDS = "e2fsprogs-native"
-PACKAGECONFIG ?= "zlib bz2 xz lzo"
+PACKAGECONFIG ?= "zlib bz2 xz lzo zstd"
PACKAGECONFIG_append_class-target = "\
${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)} \
@@ -28,6 +28,7 @@ PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo,"
PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle,"
PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
PACKAGECONFIG[mbedtls] = "--with-mbedtls,--without-mbedtls,mbedtls,"
+PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd,"
EXTRA_OECONF += "--enable-largefile"