summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-16 12:45:01 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-16 16:35:06 +0100
commit2ade2c53388c92d36b8b30dae30670fd96ca4821 (patch)
treed5f0f81207002fb8c0abef062f3a72144124c2b4 /meta/recipes-extended
parent0c68c621d3b8690e3a346170006f75b032511a8a (diff)
downloadopenembedded-core-contrib-2ade2c53388c92d36b8b30dae30670fd96ca4821.tar.gz
gettext/flex/m4/bzip2/gzip/parted/slang/attr: Add make to -ptest packages
This solves ptest runtime errors where make was missing causing the ptests to fail. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.6.bb2
-rw-r--r--meta/recipes-extended/gzip/gzip_1.10.bb2
-rw-r--r--meta/recipes-extended/parted/parted_3.2.bb2
-rw-r--r--meta/recipes-extended/slang/slang_2.3.2.bb2
4 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
index 7d04e30d53..15a8e51550 100644
--- a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
@@ -40,6 +40,8 @@ do_install_ptest () {
FILES_libbz2 = "${libdir}/lib*${SOLIBS}"
+RDEPENDS_${PN}-ptest += "make"
+
PROVIDES_append_class-native = " bzip2-replacement-native"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-extended/gzip/gzip_1.10.bb b/meta/recipes-extended/gzip/gzip_1.10.bb
index 75de970631..6a5b2459e6 100644
--- a/meta/recipes-extended/gzip/gzip_1.10.bb
+++ b/meta/recipes-extended/gzip/gzip_1.10.bb
@@ -12,6 +12,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
PROVIDES_append_class-native = " gzip-replacement-native"
+RDEPENDS_${PN}-ptest += "make"
+
BBCLASSEXTEND = "native"
inherit ptest
diff --git a/meta/recipes-extended/parted/parted_3.2.bb b/meta/recipes-extended/parted/parted_3.2.bb
index 6189fd2246..ceac52892d 100644
--- a/meta/recipes-extended/parted/parted_3.2.bb
+++ b/meta/recipes-extended/parted/parted_3.2.bb
@@ -47,7 +47,7 @@ do_install_ptest() {
sed -e 's| ../parted||' -i $t/tests/*.sh
}
-RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3"
+RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make"
inherit update-alternatives
diff --git a/meta/recipes-extended/slang/slang_2.3.2.bb b/meta/recipes-extended/slang/slang_2.3.2.bb
index e53c4321b9..e329310937 100644
--- a/meta/recipes-extended/slang/slang_2.3.2.bb
+++ b/meta/recipes-extended/slang/slang_2.3.2.bb
@@ -75,6 +75,8 @@ do_install_ptest() {
FILES_${PN} += "${libdir}/${BPN}/v2/modules/ ${datadir}/slsh/"
+RDEPENDS_${PN}-ptest += "make"
+
PARALLEL_MAKE = ""
PARALLEL_MAKEINST = ""