aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-10-12 12:46:38 +0200
committerMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2012-11-29 12:00:22 +0100
commitc884f84b1f904ceab165fb7e8969f643296e59a9 (patch)
tree34fc2bc5b05cc2b0b1fda522065190bca55870f6 /meta/recipes-extended
parent308bc0e5c7e02ba588f85a5a135d88ae8e47d3fd (diff)
downloadopenembedded-core-contrib-c884f84b1f904ceab165fb7e8969f643296e59a9.tar.gz
PACKAGES_DYNAMIC: use regexp not glob
* bitbake uses PACKAGES_DYNAMIC as regexp ^ could make matching faster (and it will be more clear that we're expecting regexp not glob) * made all those last '-' optional, use .* (or nothing) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.31.bb2
-rw-r--r--meta/recipes-extended/pam/libpam_1.1.6.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.31.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.31.bb
index 85ea7083d0..47f7538046 100644
--- a/meta/recipes-extended/lighttpd/lighttpd_1.4.31.bb
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.31.bb
@@ -56,7 +56,7 @@ FILES_${PN} += "${sysconfdir} /www"
CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
-PACKAGES_DYNAMIC = "lighttpd-module-*"
+PACKAGES_DYNAMIC = "^lighttpd-module-.*"
python populate_packages_prepend () {
lighttpd_libdir = d.expand('${libdir}')
diff --git a/meta/recipes-extended/pam/libpam_1.1.6.bb b/meta/recipes-extended/pam/libpam_1.1.6.bb
index c32cb146cd..fae0467e01 100644
--- a/meta/recipes-extended/pam/libpam_1.1.6.bb
+++ b/meta/recipes-extended/pam/libpam_1.1.6.bb
@@ -46,7 +46,7 @@ FILES_${PN}-dev += "${base_libdir}/security/*.la ${base_libdir}/*.la ${base_libd
FILES_${PN}-runtime = "${sysconfdir}"
FILES_${PN}-xtests = "${datadir}/Linux-PAM/xtests"
-PACKAGES_DYNAMIC += " pam-plugin-*"
+PACKAGES_DYNAMIC += "^pam-plugin-.*"
RDEPENDS_${PN}-runtime = "libpam pam-plugin-deny pam-plugin-permit pam-plugin-warn pam-plugin-unix"
RDEPENDS_${PN}-xtests = "libpam pam-plugin-access pam-plugin-debug pam-plugin-cracklib pam-plugin-pwhistory pam-plugin-succeed-if pam-plugin-time coreutils"