aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-22 15:06:35 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-01 16:22:42 +0100
commitcf1af6b384ab102fc3d8d703546cafcc6ffc8a0a (patch)
tree6476c48f766a957618b38f494288b4ee6cf266ea /meta/recipes-extended
parent83b11dcd55f907d845c8efa45a2616b8890f3004 (diff)
downloadopenembedded-core-contrib-cf1af6b384ab102fc3d8d703546cafcc6ffc8a0a.tar.gz
pythonnative.bbclass, python3native.bbclass: export STAGING_INCDIR, STAGING_LIBDIR, PYTHON variables
We patch Python's distutils modules to access STAGING_INCDIR/LIBDIR, so when they are not set, scripts that utilize distutils (e.g. python-config) fail. Several recipes need to export those manually to prevent such failures, so let's do that in the class instead. PYTHON variable is exported because otherwise autotools' python.m4 macro will pick up its own internal default, which may not be the version that we want. glib recipe in particular was previously using Python 2.x during build due to python.m4 defaulting to it - now it's using Python 3.x, and so needs a small fix in deletion of *.pyc files. (From OE-Core rev: c1e0eb62f2d89b10b187016200018830b1c77945) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libuser/libuser_0.62.bb2
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.19.bb2
2 files changed, 0 insertions, 4 deletions
diff --git a/meta/recipes-extended/libuser/libuser_0.62.bb b/meta/recipes-extended/libuser/libuser_0.62.bb
index 85905630a2..960f789e27 100644
--- a/meta/recipes-extended/libuser/libuser_0.62.bb
+++ b/meta/recipes-extended/libuser/libuser_0.62.bb
@@ -24,8 +24,6 @@ DEPENDS = "popt libpam glib-2.0 docbook-utils-native linuxdoc-tools-native pytho
inherit autotools gettext python3native python3-dir pkgconfig
-export PYTHON
-
EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}"
PACKAGES += "${PN}-python "
diff --git a/meta/recipes-extended/newt/libnewt_0.52.19.bb b/meta/recipes-extended/newt/libnewt_0.52.19.bb
index b45461cde3..22bdaf5ab1 100644
--- a/meta/recipes-extended/newt/libnewt_0.52.19.bb
+++ b/meta/recipes-extended/newt/libnewt_0.52.19.bb
@@ -35,8 +35,6 @@ inherit autotools-brokensep
CLEANBROKEN = "1"
-export STAGING_INCDIR
-export STAGING_LIBDIR
export CPPFLAGS
PACKAGES_prepend = "whiptail "