aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorBill Randle <william.c.randle@intel.com>2016-03-29 15:26:39 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-30 12:01:29 +0100
commit437841c1fc9ddcf3fd174bb352edba183f2ed63c (patch)
treed6e9266c04416d67e16732542f9dada3e0785270 /meta/recipes-extended
parentabb5b46ca3af3b886487799c6216eb660e860f41 (diff)
downloadopenembedded-core-contrib-437841c1fc9ddcf3fd174bb352edba183f2ed63c.tar.gz
man: fix src/Makefile to work with parallel make
The Makefile for man has a rule to create two generated targets with a program run from the shell. Because the rule was run twice, with parallel make, the generated files were being overwritten at the same time they were being compiled. This patch forces the rule to be run only once. [YOCTO #9333] (From OE-Core rev: 61f3ef6a209805577c0e731a73c4f0eab1ace748) Signed-off-by: Bill Randle <william.c.randle@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/man/man/man-1.6g-parallel.patch30
-rw-r--r--meta/recipes-extended/man/man_1.6g.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/man/man/man-1.6g-parallel.patch b/meta/recipes-extended/man/man/man-1.6g-parallel.patch
new file mode 100644
index 0000000000..72a88b898a
--- /dev/null
+++ b/meta/recipes-extended/man/man/man-1.6g-parallel.patch
@@ -0,0 +1,30 @@
+The Makefile for man has a rule to create two generated targets with
+a program run from the shell. Because the rule was run twice, with
+parallel make, the generated files were being overwritten at the same
+time they were being compiled. This patch forces the rule to be run
+only once.
+
+Upstream-Status: Pending
+
+Signed-off-by: Bill Randle <william.c.randle at intel.com>
+
+--- man-1.6g/src/Makefile.in.orig 2010-12-31 12:28:46.000000000 -0800
++++ man-1.6g/src/Makefile.in 2016-03-28 09:09:16.845458798 -0700
+@@ -43,8 +43,10 @@
+ makemsg:
+ $(BUILD_CC) -o makemsg makemsg.c
+
+-msg.c gripedefs.h: ../msgs/mess.en makemsg
++msg.c gripedefs.h: genfiles-stamp
++genfiles-stamp: ../msgs/mess.en makemsg
+ ./makemsg ../msgs/mess.en gripedefs.h msg.c
++ touch genfiles-stamp
+
+ # glob.c does not have prototypes
+ glob.o: glob.c ndir.h
+@@ -117,4 +119,4 @@
+
+ spotless: clean
+ rm -f Makefile config.status paths.h version.h man.conf
+- rm -f gripedefs.h msg.c mess.*.cat
++ rm -f gripedefs.h msg.c mess.*.cat genfiles-stamp
diff --git a/meta/recipes-extended/man/man_1.6g.bb b/meta/recipes-extended/man/man_1.6g.bb
index fa4736b298..9b057b6573 100644
--- a/meta/recipes-extended/man/man_1.6g.bb
+++ b/meta/recipes-extended/man/man_1.6g.bb
@@ -53,6 +53,7 @@ SRC_URI = "http://pkgs.fedoraproject.org/lookaside/pkgs/man2html/${BP}.tar.gz/ba
file://manpath.5.gz;unpack=false \
file://man-1.6g-whatis3.patch \
file://configure_sed.patch \
+ file://man-1.6g-parallel.patch \
"
SRC_URI[md5sum] = "ba154d5796928b841c9c69f0ae376660"