aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-02-09 18:13:50 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-12 00:31:43 +0000
commit92a9d59fccdfb6587fbd12f686899a8ace5e1d2f (patch)
treeee21a7f2eff64edb141297e75cfda174b8e45bf9 /meta/recipes-extended
parent6f6bffe5df1edf10056f42d2c95ae68b6bb918f9 (diff)
downloadopenembedded-core-contrib-92a9d59fccdfb6587fbd12f686899a8ace5e1d2f.tar.gz
recipes: pre/post actions
A number of the recipes did not properly label their pre and post actions, causing the actions to occur in all split packages. This was corrected by defaulting to _${PN} in most cases. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/bash/bash.inc2
-rw-r--r--meta/recipes-extended/bash/bash_3.2.48.bb2
-rw-r--r--meta/recipes-extended/sudo/sudo.inc2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index a87b87ff4b..ecbd75dadd 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -27,7 +27,7 @@ do_configure () {
oe_runconf
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
touch $D${sysconfdir}/shells
grep -q "bin/bash" $D${sysconfdir}/shells || echo /bin/bash >> $D${sysconfdir}/shells
grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
diff --git a/meta/recipes-extended/bash/bash_3.2.48.bb b/meta/recipes-extended/bash/bash_3.2.48.bb
index e5a3e3643d..0912ad6aa8 100644
--- a/meta/recipes-extended/bash/bash_3.2.48.bb
+++ b/meta/recipes-extended/bash/bash_3.2.48.bb
@@ -28,7 +28,7 @@ do_configure () {
oe_runconf
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
touch $D${sysconfdir}/shells
grep -q "bin/bash" $D${sysconfdir}/shells || echo /bin/bash >> $D${sysconfdir}/shells
grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
diff --git a/meta/recipes-extended/sudo/sudo.inc b/meta/recipes-extended/sudo/sudo.inc
index 1407bf10c5..6a04a9c0b0 100644
--- a/meta/recipes-extended/sudo/sudo.inc
+++ b/meta/recipes-extended/sudo/sudo.inc
@@ -23,7 +23,7 @@ do_configure_prepend () {
fi
}
-pkg_postinst() {
+pkg_postinst_${PN} () {
if [ "x$D" != "x" ]; then
exit 1
fi