aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/zypper/zypper/rpm5-flag.patch
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2011-01-11 17:09:12 +0800
committerSaul Wold <sgw@linux.intel.com>2011-01-30 12:09:52 -0800
commit114cee75bd4753c19b254a6d81b4d1284cbfa863 (patch)
tree81614d9759140182fd757b94461402342c33e19c /meta/recipes-extended/zypper/zypper/rpm5-flag.patch
parent483ee172cf522969a7e5eb7f81ba2be412db9ee4 (diff)
downloadopenembedded-core-contrib-114cee75bd4753c19b254a6d81b4d1284cbfa863.tar.gz
zypper: upgrade to newer git version
this works with rpm 5.4.0 Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-extended/zypper/zypper/rpm5-flag.patch')
-rw-r--r--meta/recipes-extended/zypper/zypper/rpm5-flag.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-extended/zypper/zypper/rpm5-flag.patch b/meta/recipes-extended/zypper/zypper/rpm5-flag.patch
new file mode 100644
index 0000000000..4403869cd2
--- /dev/null
+++ b/meta/recipes-extended/zypper/zypper/rpm5-flag.patch
@@ -0,0 +1,16 @@
+It's required by libzypp headers
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6b040a6..84431c8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -15,6 +15,7 @@ INCLUDE( ${ZYPPER_SOURCE_DIR}/VERSION.cmake )
+ SET( VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}" )
+ ADD_DEFINITIONS( -D_FILE_OFFSET_BITS=64 )
+ ADD_DEFINITIONS( -DVERSION="${VERSION}" )
++ADD_DEFINITIONS( -D_RPM_5 )
+
+ SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -Wall -Woverloaded-virtual -fstack-protector" )
+ SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g -O2 -Wall -fstack-protector" )