aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/watchdog/watchdog_5.14.bb
diff options
context:
space:
mode:
authorDiego Rondini <diego.ml@zoho.com>2015-03-18 16:50:45 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-22 09:22:09 +0000
commit415be16794dfe9122e6eedff950bede2070008ed (patch)
tree03d3f4279f974a7c555b9481bcd2dc6e07dc4aed /meta/recipes-extended/watchdog/watchdog_5.14.bb
parent53c028dcbb32792554394fb3da690f02558a9516 (diff)
downloadopenembedded-core-contrib-415be16794dfe9122e6eedff950bede2070008ed.tar.gz
watchdog: Provide and install initscript
Provide and install an initscript for the watchdog package. In particular: - watchdog-init.patch adapts redhat initscript to be compatibile with OpenEmbedded; - watchdog-conf.patch selects /dev/watchdog as default device; - changes to the recipe install and configure the initscript. Signed-off-by: Diego Rondini <diego.ml@zoho.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/watchdog/watchdog_5.14.bb')
-rw-r--r--meta/recipes-extended/watchdog/watchdog_5.14.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/meta/recipes-extended/watchdog/watchdog_5.14.bb b/meta/recipes-extended/watchdog/watchdog_5.14.bb
index c77d91dcdd..9ec0a8e84a 100644
--- a/meta/recipes-extended/watchdog/watchdog_5.14.bb
+++ b/meta/recipes-extended/watchdog/watchdog_5.14.bb
@@ -10,11 +10,21 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ecc0551bf54ad97f6b541720f84d6569"
SRC_URI = "${SOURCEFORGE_MIRROR}/watchdog/watchdog-${PV}.tar.gz \
file://fixsepbuild.patch \
- file://fix-ping-failure.patch"
+ file://fix-ping-failure.patch \
+ file://watchdog-init.patch \
+ file://watchdog-conf.patch"
SRC_URI[md5sum] = "5b2dba0c593942f4acc100bca0d560c4"
SRC_URI[sha256sum] = "620b2f49e9879f2e85c73d4c1f422f9101e6b38e824fea2414befd8bb6866ad1"
inherit autotools
+inherit update-rc.d
+
+INITSCRIPT_NAME = "watchdog.sh"
+INITSCRIPT_PARAMS = "start 15 1 2 3 4 5 . stop 85 0 6 ."
RRECOMMENDS_${PN} = "kernel-module-softdog"
+
+do_install_append() {
+ install -D ${S}/redhat/watchdog.init ${D}/${sysconfdir}/init.d/watchdog.sh
+}