aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2016j.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-12-15 07:21:44 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-17 09:57:04 +0000
commit61983b7d27cfc160955e4c074c2f555d63857b82 (patch)
tree04f6a4df746628b7a230a570f684a43de11b1106 /meta/recipes-extended/tzcode/tzcode-native_2016j.bb
parentb01f027d82711f3a1a76d0ee624f3a3d48b9f718 (diff)
downloadopenembedded-core-contrib-61983b7d27cfc160955e4c074c2f555d63857b82.tar.gz
tzcode-native: update to 2016j
Changes to code zic no longer mishandles file systems that lack hard links, fixing bugs introduced in 2016g. (Problems reported by Tom Lane.) Also, when the destination already contains symbolic links, zic should now work better on systems where the 'link' system call does not follow symbolic links. Changes to documentation and commentary tz-link.htm now documents the relationship between release version numbers and development-repository commit tags. (Suggested by Paul Koning.) The 'Theory' file now documents UT. iso3166.tab now accents "Curaçao", and commentary now mentions the names "Cabo Verde" and "Czechia". (Thanks to Jiří Boháč.) (From OE-Core rev: 3fb5ddce97af1d4ada0dcc7f9c0ceef6ac392918) (From OE-Core rev: f9d6b482f2275c054dff91b81ac901b612f9c9b4) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2016j.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2016j.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2016j.bb b/meta/recipes-extended/tzcode/tzcode-native_2016j.bb
new file mode 100644
index 0000000000..630fd42d64
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2016j.bb
@@ -0,0 +1,26 @@
+# note that we allow for us to use data later than our code version
+#
+SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+LICENSE = "PD & BSD & BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ef1a352b901ee7b75a75df8171d6aca7"
+
+SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
+ http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata"
+UPSTREAM_CHECK_URI = "http://www.iana.org/time-zones"
+
+SRC_URI[tzcode.md5sum] = "0684b98eb184fab250b6ca946862078d"
+SRC_URI[tzcode.sha256sum] = "b9effc4fb4051df4a356cbe5857bf99e2fa32e00d8340f2e8a4d58f0c9ccb0b7"
+SRC_URI[tzdata.md5sum] = "db361d005ac8b30a2d18c5ca38d3e8ab"
+SRC_URI[tzdata.sha256sum] = "f5ee4e0f115f6c2faee1c4b16193a97338cbd1b503f2cea6c5a768c82ff39dc8"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 755 zic ${D}${bindir}/
+ install -m 755 zdump ${D}${bindir}/
+ install -m 755 tzselect ${D}${bindir}/
+}