aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2016d.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-04-19 16:51:01 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-22 16:28:36 +0100
commitdb8223e4dd2e513a656aedfae217d94e053c2366 (patch)
treef456fbda07a4ff4e94d2a158b9f03ad11602fc2a /meta/recipes-extended/tzcode/tzcode-native_2016d.bb
parent271f35fb209ec29700c2cdf13c0b82d9f853f24d (diff)
downloadopenembedded-core-contrib-db8223e4dd2e513a656aedfae217d94e053c2366.tar.gz
tzcode: update to 2016d
they keep the versions in-sync. changes are all in data. Changes affecting future time stamps America/Caracas switches from -0430 to -04 on 2016-05-01 at 02:30. (Thanks to Alexander Krivenyshev for the heads-up.) Asia/Magadan switches from +10 to +11 on 2016-04-24 at 02:00. (Thanks to Alexander Krivenyshev and Matt Johnson.) New zone Asia/Tomsk, split off from Asia/Novosibirsk. It covers Tomsk Oblast, Russia, which switches from +06 to +07 on 2016-05-29 at 02:00. (Thanks to Stepan Golosunov.) Changes affecting past time stamps New zone Europe/Kirov, split off from Europe/Volgograd. It covers Kirov Oblast, Russia, which switched from +04/+05 to +03/+04 on 1989-03-26 at 02:00, roughly a year after Europe/Volgograd made the same change. (Thanks to Stepan Golosunov.) Russia and nearby locations had daylight-saving transitions on 1992-03-29 at 02:00 and 1992-09-27 at 03:00, instead of on 1992-03-28 at 23:00 and 1992-09-26 at 23:00. (Thanks to Stepan Golosunov.) Many corrections to historical time in Kazakhstan from 1991 through 2005. (Thanks to Stepan Golosunov.) Replace Kazakhstan's invented time zone abbreviations with numeric abbreviations. Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2016d.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2016d.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2016d.bb b/meta/recipes-extended/tzcode/tzcode-native_2016d.bb
new file mode 100644
index 0000000000..647ce2de5c
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2016d.bb
@@ -0,0 +1,25 @@
+# note that we allow for us to use data later than our code version
+#
+SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+LICENSE = "PD & BSD & BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=76ae2becfcb9a685041c6f166b44c2c2"
+
+SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
+ http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata"
+
+SRC_URI[tzcode.md5sum] = "06fc6fc111cd8dd681abdc5326529afd"
+SRC_URI[tzcode.sha256sum] = "a8f33d6f87aef7e109e4769fc7f6e63637d52d07ddf6440a1a50df3d9a34e0ca"
+SRC_URI[tzdata.md5sum] = "14bf84b6c2cdab0a9428991e0150ebe6"
+SRC_URI[tzdata.sha256sum] = "d9554dfba0efd76053582bd89e8c7036ef12eee14fdd506675b08a5b59f0a1b4"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 755 zic ${D}${bindir}/
+ install -m 755 zdump ${D}${bindir}/
+ install -m 755 tzselect ${D}${bindir}/
+}