summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/texinfo/texinfo_5.2.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-09-25 14:31:59 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-29 12:12:34 +0100
commit610220a95f9ef78590acb1b8f18abc984464da96 (patch)
treea8a21341bdb6739dffc23f59ca7db16528808401 /meta/recipes-extended/texinfo/texinfo_5.2.bb
parentc550cafa29b8621ef20481c873c5658f9ff6a602 (diff)
downloadopenembedded-core-contrib-610220a95f9ef78590acb1b8f18abc984464da96.tar.gz
man/texinfo: conditionally add gzip/bzip2/xz to RDEPENDS
Conditionally add 'xz/bz2/gzip' to info/man's RDEPENDS according to DOC_COMPRESS. [YOCTO #6750] [YOCTO #6751] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/texinfo/texinfo_5.2.bb')
-rw-r--r--meta/recipes-extended/texinfo/texinfo_5.2.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-extended/texinfo/texinfo_5.2.bb b/meta/recipes-extended/texinfo/texinfo_5.2.bb
index 7b5a11a874..cf9dcfd5de 100644
--- a/meta/recipes-extended/texinfo/texinfo_5.2.bb
+++ b/meta/recipes-extended/texinfo/texinfo_5.2.bb
@@ -9,6 +9,19 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
PROVIDES_append_class-native = " texinfo-replacement-native"
+def compress_pkg(d):
+ if "compress_doc" in (d.getVar("INHERIT", True) or "").split():
+ compress = d.getVar("DOC_COMPRESS", True)
+ if compress == "gz":
+ return "gzip"
+ elif compress == "bz2":
+ return "bzip2"
+ elif compress == "xz":
+ return "xz"
+ return ""
+
+RDEPENDS_info += "${@compress_pkg(d)}"
+
DEPENDS = "zlib ncurses texinfo-replacement-native"
DEPENDS_class-native = "zlib-native ncurses-native"