summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/stress-ng/stress-ng_0.11.24.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-04 21:07:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-09 12:15:17 +0000
commitfc20963ffdbc2550ba67b667013cf547632de2a6 (patch)
tree9d0c0e4d0f614524937b3bf1d172fa3b8820ac6e /meta/recipes-extended/stress-ng/stress-ng_0.11.24.bb
parentcff3a309e9285186700e5a39afc9f9bf2ae93429 (diff)
downloadopenembedded-core-contrib-fc20963ffdbc2550ba67b667013cf547632de2a6.tar.gz
stress-ng: upgrade 0.11.23 -> 0.11.24
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/stress-ng/stress-ng_0.11.24.bb')
-rw-r--r--meta/recipes-extended/stress-ng/stress-ng_0.11.24.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.11.24.bb b/meta/recipes-extended/stress-ng/stress-ng_0.11.24.bb
new file mode 100644
index 0000000000..3516c15451
--- /dev/null
+++ b/meta/recipes-extended/stress-ng/stress-ng_0.11.24.bb
@@ -0,0 +1,27 @@
+SUMMARY = "System load testing utility"
+DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
+imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
+HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
+ file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
+ file://no_daddr_t.patch \
+ "
+SRC_URI[sha256sum] = "5b3a724a85eed48743dedf37eab851b617ecf921b7fff427c6d0bbf405534671"
+
+DEPENDS = "coreutils-native"
+
+PROVIDES = "stress"
+RPROVIDES_${PN} = "stress"
+RREPLACES_${PN} = "stress"
+RCONFLICTS_${PN} = "stress"
+
+inherit bash-completion
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+ ln -s stress-ng ${D}${bindir}/stress
+}
+