aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sat-solver
diff options
context:
space:
mode:
authorYu Ke <ke.yu@intel.com>2011-07-13 16:57:39 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-13 12:14:04 +0100
commitf4de87ce30a37bb2f09855d442b34d153ada8c0e (patch)
treed7a2ee204fdff48f24ebebe57b3e16e0ba8cb202 /meta/recipes-extended/sat-solver
parent585e46e089e8863c8970a9c7c02159805e3e479a (diff)
downloadopenembedded-core-contrib-f4de87ce30a37bb2f09855d442b34d153ada8c0e.tar.gz
sat-solver: fix for non /usr/lib libdir case
when libdir set to non /usr/lib like /usr/lib64, there is do_configure error: " -- Libraries will be installed in /usr/lib CMake Error at /home/kyu3/sdb/lib64/tmp/sysroots/x86_64-linux/usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE): Please install 'check' and 'check-devel' packages (missing: CHECK_LIBRARY) Call Stack (most recent call first): /home/kyu3/sdb/lib64/tmp/sysroots/x86_64-linux/usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE) cmake/modules/FindCheck.cmake:17 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) CMakeLists.txt:35 (FIND_PACKAGE) -- Configuring incomplete, errors occurred! " The reason is that cmake did not search /usr/lib64 for libcheck, thus report error add ${libdir} to the CMAKE_SYSTEM_LIBRARY_PATH can fix this issue. Signed-off-by: Yu Ke <ke.yu@intel.com>
Diffstat (limited to 'meta/recipes-extended/sat-solver')
-rw-r--r--meta/recipes-extended/sat-solver/sat-solver_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-extended/sat-solver/sat-solver_git.bb b/meta/recipes-extended/sat-solver/sat-solver_git.bb
index c608bb7cc2..9b212dbf03 100644
--- a/meta/recipes-extended/sat-solver/sat-solver_git.bb
+++ b/meta/recipes-extended/sat-solver/sat-solver_git.bb
@@ -8,7 +8,7 @@ DEPENDS = "libcheck rpm zlib expat db"
SRCREV = "0a7378d5f482f477a01cf1690d76871ab8bdcc32"
PV = "0.0-git${SRCPV}"
-PR = "r10"
+PR = "r11"
PARALLEL_MAKE=""
@@ -23,7 +23,9 @@ SRC_URI = "git://gitorious.org/opensuse/sat-solver.git;protocol=git \
S = "${WORKDIR}/git"
-EXTRA_OECMAKE += "-DLIB=lib -DRPM5=RPM5 -DOE_CORE=OE_CORE"
+EXTRA_OECMAKE += "-DRPM5=RPM5 -DOE_CORE=OE_CORE"
+
+EXTRA_OECMAKE += " -DLIB=${@os.path.basename('${libdir}')}"
inherit cmake pkgconfig