aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/polkit
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-03-05 08:38:29 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-05 09:29:44 -0800
commit7a6fcc7f79445e5f290dd499c223619a2a426f78 (patch)
tree5449c6b9f9247da52ecc2814f28c968e9e0e2a42 /meta/recipes-extended/polkit
parent641cdbc7ee0186053dd541e0dd5fb7b03b1c10d1 (diff)
downloadopenembedded-core-contrib-7a6fcc7f79445e5f290dd499c223619a2a426f78.tar.gz
polkit 0.104: convert pam code to PACKAGECONFIG and adhere to OE recipe styleguide
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/polkit')
-rw-r--r--meta/recipes-extended/polkit/polkit_0.104.bb25
1 files changed, 15 insertions, 10 deletions
diff --git a/meta/recipes-extended/polkit/polkit_0.104.bb b/meta/recipes-extended/polkit/polkit_0.104.bb
index 2737a4a805..5dc82c5df6 100644
--- a/meta/recipes-extended/polkit/polkit_0.104.bb
+++ b/meta/recipes-extended/polkit/polkit_0.104.bb
@@ -6,28 +6,33 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4 \
file://docs/polkit/html/license.html;md5=d85a36709a446c10f4ee123f9dda0e38"
+DEPENDS = "expat dbus-glib eggdbus intltool-native"
+
+PACKAGECONFIG = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
+PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=none,libpam,libpam"
+
+PR = "r3"
+
+PAM_SRC_URI = "file://polkit-1_pam.patch"
SRC_URI = "http://hal.freedesktop.org/releases/polkit-${PV}.tar.gz \
file://introspection.patch \
- ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
+ ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
+ "
SRC_URI[md5sum] = "e380b4c6fb1e7bccf854e92edc0a8ce1"
SRC_URI[sha256sum] = "6b0a13d8381e4a7b7e37c18a54595191b50757e0fcd186cd9918e9ad0f18c7f9"
-PAM_SRC_URI = "file://polkit-1_pam.patch"
-PR = "r2"
-DEPENDS = "libpam expat dbus-glib eggdbus intltool-native"
-RDEPENDS_${PN} = "libpam"
-EXTRA_OECONF = "--with-authfw=pam --with-os-type=moblin --disable-man-pages --disable-gtk-doc --disable-introspection"
+EXTRA_OECONF = "--with-os-type=moblin --disable-man-pages --disable-gtk-doc --disable-introspection"
inherit autotools pkgconfig
+do_install_append() {
+ rm -f ${D}${libdir}/${PN}-1/extensions/*.a
+}
+
FILES_${PN} += "${libdir}/${PN}-1/extensions/*.so \
${datadir}/${PN}-1/actions/* \
${datadir}/dbus-1/system-services/*"
FILES_${PN}-dbg += "${libdir}/${PN}-1/extensions/.debug/*.so"
FILES_${PN}-dev += "${libdir}/${PN}-1/extensions/*.la "
-do_install_append() {
- rm -f ${D}${libdir}/${PN}-1/extensions/*.a
-}
-