aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt-python_0.52.17.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-06-17 15:01:05 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-17 17:55:08 +0100
commit46ec6e5601b88d4270d58586f25626349474d769 (patch)
tree295df4cc4ae755639160c8279ddcb5feb1e981fe /meta/recipes-extended/newt/libnewt-python_0.52.17.bb
parentcdbd772492812d2bd16ce9f3d5641910f9df240f (diff)
downloadopenembedded-core-contrib-46ec6e5601b88d4270d58586f25626349474d769.tar.gz
libnewt/libnewt-python: upgrade to 0.52.17
- The company address has changed in COPYING. - Rebase fix_SHAREDDIR.patch to 0.52.17 - Rebase cross_ar.patch to 0.52.17 - Obsolete fix_python_fpic.patch, since the patch has been merged by upstream; - The upstream rename snackmodule to snack in 0.52.17, so tweak libnewt-python_0.52.17.bb; Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt-python_0.52.17.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt-python_0.52.17.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt-python_0.52.17.bb b/meta/recipes-extended/newt/libnewt-python_0.52.17.bb
new file mode 100644
index 0000000000..d591fbd3d2
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt-python_0.52.17.bb
@@ -0,0 +1,27 @@
+require recipes-extended/newt/libnewt_${PV}.bb
+
+SUMMARY .= " - python"
+DEPENDS = "libnewt python"
+RDEPENDS_${PN} += "python-core"
+
+inherit pythonnative python-dir
+
+EXTRA_OECONF += "--with-python"
+EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
+
+
+do_compile () {
+ VERSION="$(sed -n 's/^VERSION = //p' Makefile)"
+ oe_runmake "LIBNEWTSH=${STAGING_LIBDIR}/libnewt.so.$VERSION" _snack.so
+}
+
+do_install () {
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}
+ install -m 0755 ${PYTHON_DIR}/_snack.so ${D}${PYTHON_SITEPACKAGES_DIR}/
+ install -m 0644 snack.py ${D}${PYTHON_SITEPACKAGES_DIR}/
+}
+
+PACKAGES_remove = "whiptail"
+
+FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug/"