summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/minicom/minicom
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2014-01-21 10:55:20 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-28 00:48:26 +0000
commit4e5a734d4d491d641efd055a4a5c4cb37e2de420 (patch)
treebc87575d6d36817a72f2e0bc434eae5327cbeeb2 /meta/recipes-extended/minicom/minicom
parent5255405d84826869638f36d2c043f3d929ebe6d6 (diff)
downloadopenembedded-core-contrib-4e5a734d4d491d641efd055a4a5c4cb37e2de420.tar.gz
minicom: upgrade to 2.7
Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/minicom/minicom')
-rw-r--r--meta/recipes-extended/minicom/minicom/0001-fix-minicom-h-v-return-value-is-not-0.patch35
-rw-r--r--meta/recipes-extended/minicom/minicom/allow.to.disable.lockdev.patch21
2 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-extended/minicom/minicom/0001-fix-minicom-h-v-return-value-is-not-0.patch b/meta/recipes-extended/minicom/minicom/0001-fix-minicom-h-v-return-value-is-not-0.patch
new file mode 100644
index 0000000000..bd8261c979
--- /dev/null
+++ b/meta/recipes-extended/minicom/minicom/0001-fix-minicom-h-v-return-value-is-not-0.patch
@@ -0,0 +1,35 @@
+Subject: [PATCH] fix minicom -h/-v return value is not 0
+
+Upstream-Status: Pending
+
+Signed-off-by: Lu Chong <Chong.Lu@windriver.com>
+
+---
+ src/minicom.c | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/src/minicom.c b/src/minicom.c
+index e1a557b..730da7c 100644
+--- a/src/minicom.c
++++ b/src/minicom.c
+@@ -1166,15 +1166,13 @@ int main(int argc, char **argv)
+ "modify it under the terms of the GNU General Public License\n"
+ "as published by the Free Software Foundation; either version\n"
+ "2 of the License, or (at your option) any later version.\n\n");
+- exit(1);
+- break;
++ exit(0);
+ case 's': /* setup mode */
+ dosetup = 1;
+ break;
+ case 'h':
+ helpthem();
+- exit(1);
+- break;
++ exit(0);
+ case 'p': /* Pseudo terminal to use. */
+ if (strncmp(optarg, "/dev/", 5) == 0)
+ optarg += 5;
+--
+1.7.9.5
+
diff --git a/meta/recipes-extended/minicom/minicom/allow.to.disable.lockdev.patch b/meta/recipes-extended/minicom/minicom/allow.to.disable.lockdev.patch
new file mode 100644
index 0000000000..f5c08896ff
--- /dev/null
+++ b/meta/recipes-extended/minicom/minicom/allow.to.disable.lockdev.patch
@@ -0,0 +1,21 @@
+Upstream-Status: Pending
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+
+--- a/configure.in 2013-02-06 18:18:13.000000000 +0100
++++ b/configure.in 2013-07-21 15:31:27.614828894 +0200
+@@ -40,7 +40,13 @@
+ fi
+
+ PKG_PROG_PKG_CONFIG
+-if test -n "$PKG_CONFIG"; then
++
++AC_ARG_ENABLE([lockdev],
++ AS_HELP_STRING([--enable-lockdev],
++ [Enable lockdev support (def: enabled)]),
++ [], [enable_lockdev="yes"])
++
++if test -n "$PKG_CONFIG" && test "x$enable_lockdev" = xyes; then
+ PKG_CHECK_MODULES([LOCKDEV], [lockdev], AC_DEFINE([HAVE_LOCKDEV],[1],[Define if you have lockdev]),[:])
+ fi
+