summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm
diff options
context:
space:
mode:
authorLiwei Song <liwei.song@windriver.com>2019-03-20 23:19:09 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-24 17:00:54 +0000
commit5b2610ee3935d12ab73164aa8716c068dc8f7f56 (patch)
tree1b8a312f6079bda85dfa3f3b48bee597c11f70aa /meta/recipes-extended/mdadm
parent9713e8a5460ae81a33c6a727664f4cdb54fb1f0a (diff)
downloadopenembedded-core-contrib-5b2610ee3935d12ab73164aa8716c068dc8f7f56.tar.gz
mdadm: add mdmon service to support Intel VROC
Install mdmon@.service to make Intel VROC work well. mdmon@.service called from udev is used to update Intel VROC metadata, with it the VROC raid is operational to read or write under user space. Signed-off-by: Liwei Song <liwei.song@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_4.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_4.1.bb b/meta/recipes-extended/mdadm/mdadm_4.1.bb
index d79c533f21..6b32f08abe 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.1.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.1.bb
@@ -26,7 +26,7 @@ SRC_URI[sha256sum] = "ab7688842908d3583a704d491956f31324c3a5fc9f6a04653cb75d19f1
inherit autotools-brokensep ptest systemd
-SYSTEMD_SERVICE_${PN} = "mdmonitor.service"
+SYSTEMD_SERVICE_${PN} = "mdmonitor.service mdmon@.service"
SYSTEMD_AUTO_ENABLE = "disable"
CFLAGS_append_toolchain-clang = " -Wno-error=address-of-packed-member"
@@ -57,6 +57,7 @@ do_install_append() {
install -m 644 ${S}/mdadm.conf-example ${D}${sysconfdir}/mdadm.conf
install -d ${D}/${systemd_unitdir}/system
install -m 644 ${WORKDIR}/mdmonitor.service ${D}/${systemd_unitdir}/system
+ install -m 644 ${S}/systemd/mdmon@.service ${D}/${systemd_unitdir}/system
install -d ${D}/${sysconfdir}/init.d
install -m 755 ${WORKDIR}/mdadm.init ${D}${sysconfdir}/init.d/mdmonitor
}