aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_3.3.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-10-16 16:40:03 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-26 15:48:47 +0100
commitdd125fc30042524079e32027f8be0784f140e379 (patch)
tree159b1f44c5555f7b755aa1c3db7adddacf1b79f4 /meta/recipes-extended/mdadm/mdadm_3.3.bb
parent0d8ff52a4c2e31c28ef9b50a4c3a380cf263992b (diff)
downloadopenembedded-core-contrib-dd125fc30042524079e32027f8be0784f140e379.tar.gz
mdadm: upgrade to 3.3
Refreshed mdadm-3.2.2_fix_for_x32.patch to apply correctly. Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_3.3.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.3.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.3.bb b/meta/recipes-extended/mdadm/mdadm_3.3.bb
new file mode 100644
index 0000000000..23c9408645
--- /dev/null
+++ b/meta/recipes-extended/mdadm/mdadm_3.3.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = " A tool for managing Soft RAID under Linux"
+HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
+BUGTRACKER = "n/a"
+
+# Some files are GPLv2+ while others are GPLv2.
+LICENSE = "GPLv2 & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
+ file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
+
+
+SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.bz2 \
+ file://mdadm-3.2.2_fix_for_x32.patch \
+ "
+
+SRC_URI[md5sum] = "8ac04259cdd74b4566c3b6dea9414b57"
+SRC_URI[sha256sum] = "9c07e518bdf3392ebac8874eb686258e10ea3ae0ff7a8acb6d014718a9c3ed45"
+
+CFLAGS += "-fno-strict-aliasing"
+
+inherit autotools
+
+# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
+do_configure_prepend () {
+ sed -i -e '/.*ansidecl.h.*/d' ${S}/sha1.h
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ export STRIP=""
+ autotools_do_install
+}
+
+FILES_${PN} += "${base_libdir}/udev/rules.d/*.rules"