summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/files/inline.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-08-22 08:52:58 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-30 12:34:14 +0100
commit0d0a591fca9fadd786f0ccda05cd68c295d6bb21 (patch)
tree1d62e65417897cc1d1cd465e4d5a17f229bd2671 /meta/recipes-extended/mdadm/files/inline.patch
parent443f9efa457ab57be8f79bccec8250678d4065c5 (diff)
downloadopenembedded-core-contrib-0d0a591fca9fadd786f0ccda05cd68c295d6bb21.tar.gz
mdadm: Upgrade mdadm_3.3.2.bb -> mdadm_3.3.4.bb
Drop upstreamed patch for gcc5 compatibility Forward port x32 patch (From OE-Core rev: 2782ae4dfb417ba377f861283792d7d9929f2ae3) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm/files/inline.patch')
-rw-r--r--meta/recipes-extended/mdadm/files/inline.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/meta/recipes-extended/mdadm/files/inline.patch b/meta/recipes-extended/mdadm/files/inline.patch
deleted file mode 100644
index 9009f0650c..0000000000
--- a/meta/recipes-extended/mdadm/files/inline.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-with gnu11 turning on a default with gcc-5 we have to abide by new inline semantics
-using 'inline' and using is in same translation unit means an external definition has to exist
-same like "external inline" in gnu89, we simply make the functions static inline since they
-are just meant to be used in this file
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Index: mdadm-3.3.2/bitmap.c
-===================================================================
---- mdadm-3.3.2.orig/bitmap.c
-+++ mdadm-3.3.2/bitmap.c
-@@ -20,7 +20,7 @@
-
- #include "mdadm.h"
-
--inline void sb_le_to_cpu(bitmap_super_t *sb)
-+static inline void sb_le_to_cpu(bitmap_super_t *sb)
- {
- sb->magic = __le32_to_cpu(sb->magic);
- sb->version = __le32_to_cpu(sb->version);
-@@ -34,7 +34,7 @@ inline void sb_le_to_cpu(bitmap_super_t
- sb->write_behind = __le32_to_cpu(sb->write_behind);
- }
-
--inline void sb_cpu_to_le(bitmap_super_t *sb)
-+static inline void sb_cpu_to_le(bitmap_super_t *sb)
- {
- sb_le_to_cpu(sb); /* these are really the same thing */
- }
-@@ -74,7 +74,7 @@ typedef struct bitmap_info_s {
- } bitmap_info_t;
-
- /* count the dirty bits in the first num_bits of byte */
--inline int count_dirty_bits_byte(char byte, int num_bits)
-+static inline int count_dirty_bits_byte(char byte, int num_bits)
- {
- int num = 0;
-