summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mc/mc_4.8.18.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-04-06 03:05:51 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-08 22:48:05 +0100
commit85decf26fe580acdf072baf561418bf73b7bfca4 (patch)
treea0af2b26c797d606d52398354da7c9b7ee6dc4e5 /meta/recipes-extended/mc/mc_4.8.18.bb
parentf3408bcf9d2710b07f5825683931e28571de130c (diff)
downloadopenembedded-core-contrib-85decf26fe580acdf072baf561418bf73b7bfca4.tar.gz
mc: replace "perl -w" with "use warnings"
The shebang's max length is usually 128 as defined in /usr/include/linux/binfmts.h: #define BINPRM_BUF_SIZE 128 There would be errors when @PERL@ (hostools/perl) is longer than 128, use '/usr/bin/env perl' can fix the problem, but '/usr/bin/env perl -w' doesn't work: /usr/bin/env: perl -w: No such file or directory So replace "perl -w" with "use warnings" to make it work. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mc/mc_4.8.18.bb')
-rw-r--r--meta/recipes-extended/mc/mc_4.8.18.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/mc/mc_4.8.18.bb b/meta/recipes-extended/mc/mc_4.8.18.bb
index 78abb275ba..17f3f73af7 100644
--- a/meta/recipes-extended/mc/mc_4.8.18.bb
+++ b/meta/recipes-extended/mc/mc_4.8.18.bb
@@ -7,6 +7,7 @@ DEPENDS = "ncurses glib-2.0 util-linux"
RDEPENDS_${PN} = "ncurses-terminfo"
SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
+ file://0001-mc-replace-perl-w-with-use-warnings.patch \
"
SRC_URI[md5sum] = "cc56f0c9abd63c4caa3636bba3a08bfb"
SRC_URI[sha256sum] = "5b591e10dcbea95233434da40cdad4663d360229adf89826576c319667c103cb"
@@ -22,6 +23,8 @@ PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x"
+CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
+
do_install_append () {
sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
sed -i -e '1s,#!.*python,#!${bindir}/env python,' ${D}${libexecdir}/mc/extfs.d/*