aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_4.02.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@enea.com>2015-08-20 13:11:27 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-24 23:45:19 +0100
commitb396c98e4379ef080ad7e90efe0d5fb21a3b046c (patch)
tree6c3d993dd47b5b5150af9e72fa5947e94cc487a3 /meta/recipes-extended/man-pages/man-pages_4.02.bb
parent1213fda2944a4c4e08f70bd2f08f9f78a50a18d9 (diff)
downloadopenembedded-core-contrib-b396c98e4379ef080ad7e90efe0d5fb21a3b046c.tar.gz
man-pages: update to 4.02
4.01 -> 4.02 Signed-off-by: Maxin B. John <maxin.john@enea.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_4.02.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_4.02.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_4.02.bb b/meta/recipes-extended/man-pages/man-pages_4.02.bb
new file mode 100644
index 0000000000..1b90a44f99
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_4.02.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Linux man-pages"
+DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
+SECTION = "console/utils"
+HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
+LICENSE = "GPLv2+"
+
+LIC_FILES_CHKSUM = "file://README;md5=8f2a3d43057d458e5066714980567a60"
+SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/Archive/${BP}.tar.gz"
+
+SRC_URI[md5sum] = "93df3279798a3345bb2c709584c83639"
+SRC_URI[sha256sum] = "42324f9ed47c89a43cb37b6bb0d5fbcad44838eee45cd394e181c98d038c49ff"
+
+RDEPENDS_${PN} = "man"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+# Only deliveres man-pages so FILES_${PN} gets everything
+FILES_${PN}-doc = ""
+FILES_${PN} = "${mandir}/*"
+
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
+ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
+ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"