summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_4.01.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-07-27 02:46:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-31 10:31:02 +0100
commitdcffae1bb40d9246436388541077c2de68a451db (patch)
tree34bda449e3ae07f24e42a7e5e58566093ee5735d /meta/recipes-extended/man-pages/man-pages_4.01.bb
parentfe20fb4e7ff720dd8d818e231a64f74d94ccb3cc (diff)
downloadopenembedded-core-contrib-dcffae1bb40d9246436388541077c2de68a451db.tar.gz
man-pages: 4.00 -> 4.01
Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_4.01.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_4.01.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_4.01.bb b/meta/recipes-extended/man-pages/man-pages_4.01.bb
new file mode 100644
index 0000000000..f6a5c492b7
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_4.01.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Linux man-pages"
+DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
+SECTION = "console/utils"
+HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
+LICENSE = "GPLv2+"
+
+LIC_FILES_CHKSUM = "file://README;md5=8f2a3d43057d458e5066714980567a60"
+SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/Archive/${BP}.tar.gz"
+
+SRC_URI[md5sum] = "575f4e8920166b1433c329bb621819d1"
+SRC_URI[sha256sum] = "ba89f3453982fae6c699a877368d51ee27883b4de709e753eee3783b447a8381"
+
+RDEPENDS_${PN} = "man"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+# Only deliveres man-pages so FILES_${PN} gets everything
+FILES_${PN}-doc = ""
+FILES_${PN} = "${mandir}/*"
+
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
+ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
+ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"