aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libtirpc/libtirpc_1.0.2.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2017-07-19 18:01:25 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-15 15:41:25 -0700
commitfa997ff110c490337c79658bdb4baf67edc65521 (patch)
tree885a7a4a8a287ee34b1a61cb8ba6286782db40aa /meta/recipes-extended/libtirpc/libtirpc_1.0.2.bb
parent19faff705a0458570bc640adbbdc07348a831b0c (diff)
downloadopenembedded-core-contrib-fa997ff110c490337c79658bdb4baf67edc65521.tar.gz
libtirpc: upgrade to 1.0.2
1.0.1 -> 1.0.2 Remove these Backported and upstreamed patches: 1. 0001-Fix-for-CVE-2017-8779.patch 2. libtirpc-0.2.1-fortify.patch 3. libtirpc-1.0.2-rc3.patc Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/libtirpc/libtirpc_1.0.2.bb')
-rw-r--r--meta/recipes-extended/libtirpc/libtirpc_1.0.2.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-extended/libtirpc/libtirpc_1.0.2.bb b/meta/recipes-extended/libtirpc/libtirpc_1.0.2.bb
new file mode 100644
index 0000000000..94fd5f99c1
--- /dev/null
+++ b/meta/recipes-extended/libtirpc/libtirpc_1.0.2.bb
@@ -0,0 +1,41 @@
+SUMMARY = "Transport-Independent RPC library"
+DESCRIPTION = "Libtirpc is a port of Suns Transport-Independent RPC library to Linux"
+SECTION = "libs/network"
+HOMEPAGE = "http://sourceforge.net/projects/libtirpc/"
+BUGTRACKER = "http://sourceforge.net/tracker/?group_id=183075&atid=903784"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f835cce8852481e4b2bbbdd23b5e47f3 \
+ file://src/netname.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24"
+
+PROVIDES = "virtual/librpc"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.bz2;name=libtirpc \
+ ${GENTOO_MIRROR}/${BPN}-glibc-nfs.tar.xz;name=glibc-nfs \
+ file://export_key_secretkey_is_set.patch \
+ file://0001-replace-__bzero-with-memset-API.patch \
+ file://0001-include-stdint.h-for-uintptr_t.patch \
+ "
+
+SRC_URI_append_libc-uclibc = " file://remove-des-functionality.patch \
+ "
+
+SRC_URI_append_libc-musl = " \
+ file://Use-netbsd-queue.h.patch \
+ "
+
+SRC_URI[libtirpc.md5sum] = "d5a37f1dccec484f9cabe2b97e54e9a6"
+SRC_URI[libtirpc.sha256sum] = "723c5ce92706cbb601a8db09110df1b4b69391643158f20ff587e20e7c5f90f5"
+SRC_URI[glibc-nfs.md5sum] = "5ae500b9d0b6b72cb875bc04944b9445"
+SRC_URI[glibc-nfs.sha256sum] = "2677cfedf626f3f5a8f6e507aed5bb8f79a7453b589d684dbbc086e755170d83"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-gssapi"
+
+do_configure_prepend () {
+ cp -r ${WORKDIR}/tirpc ${S}
+}
+
+do_install_append() {
+ chown root:root ${D}${sysconfdir}/netconfig
+}