aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libsolv/libsolv_0.6.29.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-10-04 17:00:37 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-09 12:33:09 +0000
commit9d0eadf0e0dad97c92a34062a6acf005922039e5 (patch)
treeca8e1b17a0483844b12ce73015081a8c7fc6a993 /meta/recipes-extended/libsolv/libsolv_0.6.29.bb
parent32569391c62c96fb133c6d92f32f474b2119ec2b (diff)
downloadopenembedded-core-contrib-9d0eadf0e0dad97c92a34062a6acf005922039e5.tar.gz
libsolv: update to 0.6.29
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/libsolv/libsolv_0.6.29.bb')
-rw-r--r--meta/recipes-extended/libsolv/libsolv_0.6.29.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-extended/libsolv/libsolv_0.6.29.bb b/meta/recipes-extended/libsolv/libsolv_0.6.29.bb
new file mode 100644
index 0000000000..e216921ea4
--- /dev/null
+++ b/meta/recipes-extended/libsolv/libsolv_0.6.29.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Library for solving packages and reading repositories"
+HOMEPAGE = "https://github.com/openSUSE/libsolv"
+BUGTRACKER = "https://github.com/openSUSE/libsolv/issues"
+SECTION = "devel"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
+
+DEPENDS = "expat zlib rpm"
+
+SRC_URI = "git://github.com/openSUSE/libsolv.git \
+ file://0001-repo_rpmdb.c-increase-MAX_HDR_CNT-and-MAX_HDR_DSIZE.patch \
+ "
+SRC_URI_append_libc-musl = " file://0001-Add-fallback-fopencookie-implementation.patch \
+ file://0002-Fixes-to-internal-fopencookie-implementation.patch \
+ "
+
+SRCREV = "765be095eaeaef1b1d2a84f6a0e00d5abf677ae9"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "-DLIB=${baselib} -DMULTI_SEMANTICS=ON -DENABLE_RPMMD=ON -DENABLE_RPMDB=ON -DENABLE_COMPLEX_DEPS=ON"
+
+PACKAGES =+ "${PN}-tools ${PN}ext"
+
+FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibSolv.cmake"
+FILES_${PN}-tools = "${bindir}/*"
+FILES_${PN}ext = "${libdir}/${PN}ext.so.*"
+
+BBCLASSEXTEND = "native nativesdk"