aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libnss-nis
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-04-28 00:32:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-09 10:39:35 +0100
commitcabef0916d860449bfbcc4ff596ec9f0029849e9 (patch)
tree959013274915834096e0e69656b79273573658e1 /meta/recipes-extended/libnss-nis
parent290e7111a7b97305715f3db8cc678b9d1cc75726 (diff)
downloadopenembedded-core-contrib-cabef0916d860449bfbcc4ff596ec9f0029849e9.tar.gz
libnss-nis: Add recipe
This will substitute the glibc nis module which has been removed Skip for non-glibc systems Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-extended/libnss-nis')
-rw-r--r--meta/recipes-extended/libnss-nis/libnss-nis.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/libnss-nis/libnss-nis.bb b/meta/recipes-extended/libnss-nis/libnss-nis.bb
new file mode 100644
index 0000000000..e0f69b02ef
--- /dev/null
+++ b/meta/recipes-extended/libnss-nis/libnss-nis.bb
@@ -0,0 +1,36 @@
+# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "NSS module for glibc, to provide NIS support for glibc"
+
+DESCRIPTION = "This package contains the NSS NIS plugin for glibc.\
+This code was formerly part of glibc, but is now standalone to\
+be able to link against TI-RPC for IPv6 support."
+
+HOMEPAGE = "https://github.com/thkukuk/libnss_nis"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+SECTION = "libs"
+DEPENDS += "libtirpc libnsl2"
+
+PV = "3.0+git${SRCPV}"
+
+SRCREV = "d4aea48657a8e90d7922574b8021ee03915a36cb"
+
+SRC_URI = "git://github.com/thkukuk/libnss_nis \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+BBCLASSEXTEND += "native nativesdk"
+#
+# We will skip parsing this packagegeoup for non-glibc systems
+#
+python __anonymous () {
+ if d.getVar('TCLIBC') != "glibc":
+ raise bb.parse.SkipRecipe("incompatible with %s C library" %
+ d.getVar('TCLIBC'))
+}
+