aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/hdparm/hdparm_9.53.bb
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2018-01-25 16:13:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-29 08:49:43 +0000
commitf818d257ebd80714c5fcb243284188f6ec5c5daa (patch)
tree0d55075ab29d03b194de75f3905777cebc47ad4b /meta/recipes-extended/hdparm/hdparm_9.53.bb
parentaf2f545a5fb0a622a2f21ce0912d543529f048c7 (diff)
downloadopenembedded-core-contrib-f818d257ebd80714c5fcb243284188f6ec5c5daa.tar.gz
hdparm: 9.52 -> 9.53
Upgrade hdparm from 9.52 to 9.53. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/hdparm/hdparm_9.53.bb')
-rw-r--r--meta/recipes-extended/hdparm/hdparm_9.53.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-extended/hdparm/hdparm_9.53.bb b/meta/recipes-extended/hdparm/hdparm_9.53.bb
new file mode 100644
index 0000000000..4c3ec5c48c
--- /dev/null
+++ b/meta/recipes-extended/hdparm/hdparm_9.53.bb
@@ -0,0 +1,43 @@
+SUMMARY = "Utility for viewing/manipulating IDE disk drive/driver parameters"
+HOMEPAGE = "http://sourceforge.net/projects/hdparm/"
+DESCRIPTION = "hdparm is a Linux shell utility for viewing \
+and manipulating various IDE drive and driver parameters."
+SECTION = "console/utils"
+
+LICENSE = "BSD & GPLv2"
+LICENSE_${PN} = "BSD"
+LICENSE_${PN}-dbg = "BSD"
+LICENSE_wiper = "GPLv2"
+
+LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=495d03e50dc6c89d6a30107ab0df5b03 \
+ file://debian/copyright;md5=a82d7ba3ade9e8ec902749db98c592f3 \
+ file://wiper/GPLv2.txt;md5=fcb02dc552a041dee27e4b85c7396067 \
+ file://wiper/wiper.sh;beginline=7;endline=31;md5=b7bc642addc152ea307505bf1a296f09"
+
+
+PACKAGES =+ "wiper"
+
+FILES_wiper = "${bindir}/wiper.sh"
+
+RDEPENDS_wiper = "bash gawk coreutils"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/${BP}.tar.gz \
+ file://wiper.sh-fix-stat-path.patch \
+ "
+
+SRC_URI[md5sum] = "1e54b52e0c8cb79389d4d47eacba411d"
+SRC_URI[sha256sum] = "2673f591df6916c6a1faec07069a7eb1cb8ee307615a615d808192fb0c0265e5"
+
+EXTRA_OEMAKE = 'STRIP="echo" LDFLAGS="${LDFLAGS}"'
+
+inherit update-alternatives
+
+ALTERNATIVE_${PN} = "hdparm"
+ALTERNATIVE_LINK_NAME[hdparm] = "${base_sbindir}/hdparm"
+ALTERNATIVE_PRIORITY = "100"
+
+do_install () {
+ install -d ${D}/${base_sbindir} ${D}/${mandir}/man8 ${D}/${bindir}
+ oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
+ cp ${S}/wiper/wiper.sh ${D}/${bindir}
+}