aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/hdparm/hdparm_9.43.bb
diff options
context:
space:
mode:
authorRadu Moisan <radu.moisan@intel.com>2013-03-13 18:49:12 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 13:17:33 +0000
commitc2c0876045e2a90b7158d3e81727205eb1c0d6ea (patch)
tree9f2af772595698b31da114550df056ca5c6c0ef4 /meta/recipes-extended/hdparm/hdparm_9.43.bb
parentecdca4350a27708105692b6927f356ba0917422c (diff)
downloadopenembedded-core-contrib-c2c0876045e2a90b7158d3e81727205eb1c0d6ea.tar.gz
hdparm: Upgrade to v9.43
Signed-off-by: Radu Moisan <radu.moisan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/hdparm/hdparm_9.43.bb')
-rw-r--r--meta/recipes-extended/hdparm/hdparm_9.43.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/hdparm/hdparm_9.43.bb b/meta/recipes-extended/hdparm/hdparm_9.43.bb
new file mode 100644
index 0000000000..03714778c4
--- /dev/null
+++ b/meta/recipes-extended/hdparm/hdparm_9.43.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "hdparm is a Linux shell utility for viewing \
+and manipulating various IDE drive and driver parameters."
+SECTION = "console/utils"
+LICENSE = "BSD"
+LICENSE_wiper = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=910a8a42c962d238619c75fdb78bdb24 \
+ file://debian/copyright;md5=a82d7ba3ade9e8ec902749db98c592f3 \
+ file://wiper/GPLv2.txt;md5=fcb02dc552a041dee27e4b85c7396067 \
+ file://wiper/wiper.sh;beginline=7;endline=31;md5=b7bc642addc152ea307505bf1a296f09"
+
+PR = "r0"
+
+PACKAGES += "wiper"
+
+FILES_wiper = "${bindir}/wiper.sh"
+
+RDEPENDS_wiper = "bash gawk stat"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/hdparm-${PV}.tar.gz "
+
+SRC_URI[md5sum] = "f73233be118d86c779a8463d8b6a3cdb"
+SRC_URI[sha256sum] = "2bbe92274971182192901ab220e94bd2e4896f924fa6b225d0cffd7d8c16b52a"
+
+EXTRA_OEMAKE += 'STRIP="echo"'
+
+inherit update-alternatives
+
+ALTERNATIVE_${PN} = "hdparm"
+ALTERNATIVE_LINK_NAME[hdparm] = "${base_sbindir}/hdparm"
+ALTERNATIVE_PRIORITY = "100"
+
+do_install () {
+ install -d ${D}/${base_sbindir} ${D}/${mandir}/man8 ${D}/${bindir}
+ oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
+ cp ${S}/wiper/wiper.sh ${D}/${bindir}
+}